Modify

Opened 3 years ago

Closed 2 years ago

#19911 closed defect (upstream)

luci-app-statistics broken

Reported by: anonymous Owned by: developers
Priority: highest Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

WRT1900AC Mamba

Installing luci-app-statistics (git-15.168.50780-bae48b6-1) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/mvebu/generic/packages/luci/luci-app-statistics_git-15.168.50780-bae48b6-1_all.ipk.

Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-statistics:
  • collectd * collectd-mod-rrdtool * collectd-mod-iwinfo * collectd-mod-interface * collectd-mod-load * collectd-mod-network *
  • opkg_install_cmd: Cannot install package luci-app-statistics.

Attachments (0)

Change History (8)

comment:1 follow-up: Changed 3 years ago by kroimon

Can confirm this issue.

Seems like the collectd packages are currently missing from https://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages/packages/

comment:2 Changed 3 years ago by anonymous

Any fix in the works?

comment:3 in reply to: ↑ 1 Changed 3 years ago by anonymous

Replying to kroimon:

Can confirm this issue.

Seems like the collectd packages are currently missing from https://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages/packages/

Yes, same problem here. Missing in the buildroot.

comment:4 Changed 2 years ago by anonymous

Problem still there, building fails when I include luci-app-statistics (because of missing collectd).
Strangely though it worked in build r46421 which I built 2015-08-03 which was AFTER this defect was reported, so it was fixed and then now it is missing again?

comment:5 Changed 2 years ago by anonymous

It works! Ticket should be closed.

comment:6 Changed 2 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

comment:7 Changed 2 years ago by ulrich

  • Resolution fixed deleted
  • Status changed from closed to reopened

Imagebuilder from 18-Oct-2015 (ar71xx/generic) does not contain collectd:

Collected errors:
 * opkg_install_cmd: Cannot install package collectd.
 * opkg_install_cmd: Cannot install package collectd-mod-conntrack.
 * opkg_install_cmd: Cannot install package collectd-mod-cpu.
 * opkg_install_cmd: Cannot install package collectd-mod-memory.
 * opkg_install_cmd: Cannot install package collectd-mod-ping.
 * opkg_install_cmd: Cannot install package collectd-mod-uptime.
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-statistics:
 * 	collectd * 	collectd-mod-rrdtool * 	collectd-mod-iwinfo * 	collectd-mod-interface * 	collectd-mod-load * 	collectd-mod-network * 

comment:8 Changed 2 years ago by jow

  • Resolution set to upstream
  • Status changed from reopened to closed

Transient error because lm-sensors (build dep of collectd) repo was unreachable during the last build cycle (http://buildbot.openwrt.org:8010/broken_packages/ar71xx/lm-sensors/compile.txt). I uploaded the sources to our mirror now (https://downloads.openwrt.org/sources/lm_sensors-3.3.5.tar.bz2). The problem will solve itself with the next build cycle.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.