Modify

Opened 3 years ago

Last modified 22 months ago

#19882 reopened defect

kmod-fs-exfat

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: exfat Cc: 15.05-RC2

Description

Hello.
I have tp-link "wr-842nd v2" OpenWRT-RC2 and you can not install exFAT.
root@OpenWrt:~# opkg install kmod-fs-exfat
Installing kmod-fs-exfat (3.18.14+git-20150301-1) to root...
Downloading http://downloads.openwrt.org/chaos_calmer/15.05-rc2/ar71xx/generic/packages/packages/kmod-fs-exfat_3.18.14+git-20150301-1_ar71xx.ipk.
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-fs-exfat:
  • kernel (= 3.18.14-1-406f55e08cbd4433be5683443e405921) *
  • opkg_install_cmd: Cannot install package kmod-fs-exfat.

The same is on Asus RT-N16 (brcm47xx/mips74k) :(
Best regards.

Attachments (0)

Change History (14)

comment:1 follow-ups: Changed 3 years ago by anonymous

shouldn't the binary release be built with CONFIG_BUILD_PATENTED=n ?

comment:2 in reply to: ↑ 1 Changed 3 years ago by anonymous

Replying to anonymous:

shouldn't the binary release be built with CONFIG_BUILD_PATENTED=n ?

Why is a package in the repository if you can not install it?
I have this image (http://downloads.openwrt.org/chaos_calmer/15.05-rc2/ar71xx/generic/openwrt-15.05-rc2-ar71xx-generic-tl-wr842n-v2-squashfs-sysupgrade.bin ) I do not compile.

comment:3 in reply to: ↑ 1 Changed 3 years ago by anonymous

Replying to anonymous:

shouldn't the binary release be built with CONFIG_BUILD_PATENTED=n ?

Why is a package in the repository if you can not install it?
I have this image (http://downloads.openwrt.org/chaos_calmer/15.05-rc2/ar71xx/generic/openwrt-15.05-rc2-ar71xx-generic-tl-wr842n-v2-squashfs-sysupgrade.bin ) I do not compile.

comment:4 Changed 3 years ago by anonymous

This is also a problem with TL-WDR3600

comment:5 Changed 3 years ago by hauke

We had some problems in the build process of rc2, can you please try 15.05-rc3.

comment:6 Changed 3 years ago by HomerSp

This is still an issue with rc3 on the Linksys WRT1900AC (mvebu). The kmod-fs-exfat package depends on kernel=3.18.14-1-284458b50ddb1addf8518a4fd3eacd0c, while the kernel that's installed is 3.18.17-1-ea890e6ccd016d26700d53d207016b91.

comment:7 Changed 2 years ago by imago

Issue confirmed on OpenWrt Chaos Calmer 15.05-rc3 / LuCI (git-15.167.71950-8005ecb) TP-LINK TL-WR703N v1.

comment:8 Changed 2 years ago by @…

I have the same issue on 15.05-rc3, but is working on RC1

root@OpenWrt:~# opkg install kmod-fs-exfat
Installing kmod-fs-exfat (3.18.14+git-20150301-1) to root...
Downloading http://downloads.openwrt.org/chaos_calmer/15.05-rc3/mvebu/generic/packages/packages/kmod-fs-exfat_3.18.14+git-20150301-1_mvebu.ipk.
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-fs-exfat:
  • kernel (= 3.18.14-1-284458b50ddb1addf8518a4fd3eacd0c) *
  • opkg_install_cmd: Cannot install package kmod-fs-exfat.

comment:9 Changed 2 years ago by rmilecki

It should be fixed in 15.05 final, please test.

comment:10 Changed 2 years ago by rmilecki

  • Resolution set to fixed
  • Status changed from new to closed

If you're upgrading, please execute manually:

cp /rom/etc/opkg.conf /etc/opkg.conf

This is because 15.05 (and release candidates as well) preserve(s) opkg.conf. This was fixed for the next release in r46491.

comment:11 Changed 23 months ago by Elektronik

  • Resolution fixed deleted
  • Status changed from closed to reopened

The issue came up again with the latest CC release: 15.05.1, r48532
Clean install of CC. (sysupgrade + firstboot):

Installing kmod-fs-exfat (3.18.21+git-20150301-1) to root...
Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/packages/kmod-fs-exfat_3.18.21+git-20150301-1_ar71xx.ipk.
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-fs-exfat:
  • kernel (= 3.18.21-1-3d4bd113f3f10b8986a142b8792db9c5) *
  • opkg_install_cmd: Cannot install package kmod-fs-exfat.

comment:12 Changed 22 months ago by kursatgoker@…

I have that error also. Please someone can help. Is it possible to bypass that error and install anyway?

comment:13 follow-up: Changed 22 months ago by anonymous

Same error here:

Installing kmod-fs-exfat (3.18.21+git-20150301-1) to root...
Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/packages/kmod-fs-exfat_3.18.21+git-20150301-1_ar71xx.ipk.
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-fs-exfat:
  • kernel (= 3.18.21-1-3d4bd113f3f10b8986a142b8792db9c5) *
  • opkg_install_cmd: Cannot install package kmod-fs-exfat.

comment:14 in reply to: ↑ 13 Changed 22 months ago by hnyman

Replying to anonymous:

Installing kmod-fs-exfat (3.18.21+git-20150301-1) to root...
Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/packages/kmod-fs-exfat_3.18.21+git-20150301-1_ar71xx.ipk.

Looks like a duplicate of #22073 and #22212

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.