Modify

Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#19799 closed defect (fixed)

Apple drops off 5ghz network on Archer C7 on CC

Reported by: hendry Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: apple Cc:

Description

I successfully setup 15.05-rc1 on my Archer C7. The IRC channel was helpful and I think opkg install kmod-ath10k got my 5ghz going.

I'm unsure about the channel and txpower values:
http://s.natalian.org/2015-06-04/etc-config-wireless.txt

Especially since luci, the Web interface seemed unresponsive. I'm in Singapore btw.

The problem is my Archlinux machine behaves fine. But my wife's Apple MBP 2013 model doesn't. Same issue with my iPhone6. It just drops off the 5ghz and favours my other 2.4Ghz AP, where it's stable.

MBP wireless diagnostics:
http://s.natalian.org/2015-06-04/WirelessDiagnostics_C02LN3SJFH00_2015-06-03_10.03.08.tar.gz

This is the interesting part from logread: http://ix.io/iVT

Thu Jun  4 11:32:02 2015 daemon.info hostapd: wlan1: STA 60:57:18:8f:e8:e6 WPA: group key handshake completed (RSN)
Thu Jun  4 11:35:17 2015 daemon.info hostapd: wlan1: STA 70:3e:ac:32:95:a8 IEEE 802.11: authenticated
Thu Jun  4 11:35:17 2015 daemon.info hostapd: wlan1: STA 70:3e:ac:32:95:a8 IEEE 802.11: authenticated
Thu Jun  4 11:35:17 2015 daemon.info hostapd: wlan1: STA 70:3e:ac:32:95:a8 IEEE 802.11: authenticated
Thu Jun  4 11:35:18 2015 daemon.info hostapd: wlan1: STA 70:3e:ac:32:95:a8 IEEE 802.11: authenticated
Thu Jun  4 11:35:18 2015 daemon.info hostapd: wlan1: STA 70:3e:ac:32:95:a8 IEEE 802.11: associated (aid 2)
Thu Jun  4 11:35:18 2015 daemon.info hostapd: wlan1: STA 70:3e:ac:32:95:a8 IEEE 802.11: authenticated
Thu Jun  4 11:35:18 2015 daemon.info hostapd: wlan1: STA 70:3e:ac:32:95:a8 IEEE 802.11: associated (aid 2)
Thu Jun  4 11:35:21 2015 kern.warn kernel: [159782.890000] ath10k_warn: 20 callbacks suppressed
Thu Jun  4 11:35:21 2015 kern.warn kernel: [159782.890000] ath10k_pci 0000:01:00.0: failed to delete peer 70:3e:ac:32:95:a8 for vdev 0: -145
Thu Jun  4 11:35:21 2015 daemon.info hostapd: wlan1: STA 70:3e:ac:32:95:a8 WPA: pairwise key handshake completed (RSN)
Thu Jun  4 11:35:27 2015 daemon.info hostapd: wlan1: STA 70:3e:ac:32:95:a8 IEEE 802.11: disconnected due to excessive missing ACKs
Thu Jun  4 11:35:27 2015 kern.warn kernel: [159789.090000] ath10k_pci 0000:01:00.0: Spurious quick kickout for STA 70:3e:ac:32:95:a8
Thu Jun  4 11:35:27 2015 kern.warn kernel: [159789.120000] ath10k_pci 0000:01:00.0: Spurious quick kickout for STA 70:3e:ac:32:95:a8
Thu Jun  4 11:35:27 2015 kern.warn kernel: [159789.160000] ath10k_pci 0000:01:00.0: Spurious quick kickout for STA 70:3e:ac:32:95:a8
Thu Jun  4 11:35:27 2015 kern.warn kernel: [159789.180000] ath10k_pci 0000:01:00.0: Spurious quick kickout for STA 70:3e:ac:32:95:a8
Thu Jun  4 11:35:30 2015 kern.warn kernel: [159792.060000] ath10k_pci 0000:01:00.0: failed to delete peer 70:3e:ac:32:95:a8 for vdev 0: -145
Thu Jun  4 11:35:30 2015 kern.warn kernel: [159792.170000] ath10k_pci 0000:01:00.0: SWBA overrun on vdev 0, skipped old beacon
Thu Jun  4 11:35:30 2015 kern.warn kernel: [159792.280000] ath10k_pci 0000:01:00.0: SWBA overrun on vdev 0, skipped old beacon
Thu Jun  4 11:35:30 2015 kern.warn kernel: [159792.380000] ath10k_pci 0000:01:00.0: SWBA overrun on vdev 0, skipped old beacon
Thu Jun  4 11:35:31 2015 kern.warn kernel: [159792.480000] ath10k_pci 0000:01:00.0: SWBA overrun on vdev 0, skipped old beacon
Thu Jun  4 11:35:40 2015 daemon.info hostapd: wlan1: STA 70:3e:ac:32:95:a8 IEEE 802.11: authenticated
Thu Jun  4 11:35:41 2015 daemon.info hostapd: wlan1: STA 70:3e:ac:32:95:a8 IEEE 802.11: authenticated
Thu Jun  4 11:35:41 2015 daemon.info hostapd: wlan1: STA 70:3e:ac:32:95:a8 IEEE 802.11: authenticated
Thu Jun  4 11:35:41 2015 daemon.info hostapd: wlan1: STA 70:3e:ac:32:95:a8 IEEE 802.11: associated (aid 2)
Thu Jun  4 11:35:41 2015 daemon.info hostapd: wlan1: STA 70:3e:ac:32:95:a8 WPA: pairwise key handshake completed (RSN)

I was trying to get my iPhone6 to join it, but it won't do so.

Attachments (0)

Change History (16)

comment:1 Changed 3 years ago by jamesmackenzie

Related to #19741?

comment:2 Changed 3 years ago by Sasha_Beluj

And to the #19648 which I created.
Dear developers please address your attention this issue - it's not "one-time" problem and occurs for other people too.

comment:3 follow-up: Changed 3 years ago by anonymous

I think this is fixed in the latest ath10k driver. See ath-next.

comment:4 in reply to: ↑ 3 Changed 3 years ago by Sasha_Beluj

Replying to anonymous:

I think this is fixed in the latest ath10k driver. See ath-next.

Any ideas how to bring the latest ath10k driver to OpenWrt firmware?

Because of this issue I had to disable 5Ghz at all because it was continuously failing.

comment:5 Changed 3 years ago by anonymous

Same issue on my Archer C7. CC rc2

comment:6 Changed 3 years ago by anonymous

Here's what my Apple iPad does with the latest trunk snapshot.

[1818131.990000] ath10k_pci 0000:01:00.0: Spurious quick kickout for STA b8:e8:56:40:48:e2
[1819779.320000] ath10k_pci 0000:01:00.0: failed to delete peer b8:e8:56:40:48:e2 for vdev 0: -145
[1820289.230000] ath10k_pci 0000:01:00.0: failed to delete peer b8:e8:56:40:48:e2 for vdev 0: -145
[1820968.100000] ath10k_pci 0000:01:00.0: SWBA overrun on vdev 0, skipped old beacon
[1820968.200000] ath10k_pci 0000:01:00.0: SWBA overrun on vdev 0, skipped old beacon
[1820968.300000] ath10k_pci 0000:01:00.0: SWBA overrun on vdev 0, skipped old beacon
[1821674.750000] ath10k_pci 0000:01:00.0: failed to delete peer b8:e8:56:40:48:e2 for vdev 0: -145
[1822403.890000] ath10k_pci 0000:01:00.0: reached WMI management transmit queue limit
[1822403.900000] ath10k_pci 0000:01:00.0: failed to transmit packet, dropping: -16
[1822403.910000] ath10k_pci 0000:01:00.0: reached WMI management transmit queue limit
[1822403.920000] ath10k_pci 0000:01:00.0: failed to transmit packet, dropping: -16
[1822403.930000] ath10k_pci 0000:01:00.0: reached WMI management transmit queue limit
[1822403.940000] ath10k_pci 0000:01:00.0: failed to transmit packet, dropping: -16
[1822403.950000] ath10k_pci 0000:01:00.0: reached WMI management transmit queue limit
[1822403.950000] ath10k_pci 0000:01:00.0: failed to transmit packet, dropping: -16
[1822403.960000] ath10k_pci 0000:01:00.0: reached WMI management transmit queue limit
[1824637.140000] ath10k_warn: 411 callbacks suppressed
[1824637.140000] ath10k_pci 0000:01:00.0: failed to delete peer b8:e8:56:40:48:e2 for vdev 0: -145
[1825281.710000] ath10k_pci 0000:01:00.0: failed to delete peer b8:e8:56:40:48:e2 for vdev 0: -145
[1825948.370000] ath10k_pci 0000:01:00.0: failed to delete peer b8:e8:56:40:48:e2 for vdev 0: -145
[1826605.590000] ath10k_pci 0000:01:00.0: failed to delete peer b8:e8:56:40:48:e2 for vdev 0: -145
[1826941.210000] ath10k_pci 0000:01:00.0: failed to delete peer b8:e8:56:40:48:e2 for vdev 0: -145
[1830751.000000] ath10k_pci 0000:01:00.0: Spurious quick kickout for STA b8:e8:56:40:48:e2

Needless to say, iPad is falling back to 2.4Ghz and dealing with interference from my neighbors. Does someone know how to update ath10k so we can test the latest?

comment:7 Changed 3 years ago by anonymous

I'm happy to report trunk r46205 includes the latest mac80211 and ath10k firmware/driver. I tested it all day and it's been working great with iPad, Macbooks and many other devices. Kudos to the developers, thank you!

comment:8 Changed 3 years ago by shonjir

I backported this to my own CC build (r46244) for my Archer-C7 and it seems to be working fine so far. Time will tell...

comment:9 Changed 3 years ago by stixpjr

I'm also seeing, eg:

Wed Jul 15 09:26:45 2015 daemon.info hostapd: wlan0: STA 20:02:af:fc:23:8c IEEE 802.11: disconnected due to excessive missing ACKs

This is on a Asus RT-N56U (Ralink RT3883) running Chaos Calmer r46317, with rt2800pci wifi. I've seen it on both 2.4GHz and 5GHz radios. Temporary workaround of "option disassoc_low_ack 0" seems to work.

comment:10 Changed 3 years ago by stixpjr

Ok, maybe the temporary workaround isn't so great: it seems to cause the wifi stack to hang, requiring a reboot, on a Samsung 303C chromebook.

comment:11 Changed 3 years ago by stixpjr

For completeness, the chromebook bug is:
https://code.google.com/p/chromium/issues/detail?id=439818

comment:12 follow-up: Changed 2 years ago by pierre.gaufillet@…

Hi!

I am facing the same behaviour on r46738 with tp-link archer c7 v2 and a Macbook Pro Retina 13.

comment:13 Changed 2 years ago by anonymous

This is fixed in trunk r46205 but so far the updated mac80211 package hasn't been backported by the devs.

I've been running my backported mac80211 package from on CC for the past 8 weeks and it's been extremely stable with my Mac and mobile devices (iphone and android).

I don't see why this shouldn't be backported to CC.

@nbd?

comment:14 in reply to: ↑ 12 Changed 2 years ago by pierre.gaufillet@…

Replying to pierre.gaufillet@…:

Hi!

I am facing the same behaviour on r46738 with tp-link archer c7 v2 and a Macbook Pro Retina 13.

I have realized my build was configured with firmware-2 (fallback option for ath10k firmware). Since I switched to firmware-5 these messages have disappeared.

comment:15 Changed 2 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

comment:16 Changed 2 years ago by anonymous

As I'm having the issue as well I guess the fix didn't make it into the stable release of CC...
does anyone have a hint on how to backport the correct package(s)?

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.