Modify

Opened 3 years ago

Closed 3 years ago

#19715 closed defect (fixed)

Soft-brick with K3.18.14 on Asus RT-N13U (and possibly other ramips boards)

Reported by: AndreiM Owned by: developers
Priority: response-needed Milestone:
Component: kernel Version: Trunk
Keywords: Cc: jogo

Description

After the transition to kernel 3.18.14 (r45710 & r45711), none of the RT-N13U images boot anymore (failsafe, ditto). I've been building my own, and there must be a problem with the refreshed ramips/rt2x00 patches. I reset head to r45709, and was able to TFTP upload and restore from backup, thankfully. Since I didn't have to open up the router (again ;-) to connect to serial console, I don't have any usable log, but hopefully the problem can identified upon simple inspection of the changed patches.

P.S. No problems with trunk on an ar71xx board (WNR2000v3).

Attachments (0)

Change History (8)

comment:1 follow-up: Changed 3 years ago by jogo

  • Resolution set to fixed
  • Status changed from new to closed

Hopefully fixed in r45747, thanks for reporting.

comment:2 in reply to: ↑ 1 Changed 3 years ago by AndreiM

Thanks for looking into this. Unfortunately, r45747 doesn't fix it; still no LED blinking, or response over wired. I will check later in the day to make sure I can still TFTP upload.

comment:3 Changed 3 years ago by AndreiM

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:4 Changed 3 years ago by jogo

  • Priority changed from high to response-needed

Just to be sure, you did clean the kernel?

comment:5 Changed 3 years ago by anonymous

I tested it myself all works fine now. For now I tested only chines clone with smaller ram and flash but basically the same as I use rt-n13u firmware.

comment:6 Changed 3 years ago by AndreiM

I always make clean, and last night made dirclean. Is there an additional clean target for kernel? Either way, I will try a few more things before taking the screws off and connecting to serial console. Hopefully, I can provide proper boot logs.

P.S. There may be more factors involved; I just discovered that r45754 (musl 1.1.9) breaks all my routers (rt305x & ar71xx). I will start with a clean config using uClibc, and will report back.

Last edited 3 years ago by AndreiM (previous) (diff)

comment:7 Changed 3 years ago by AndreiM

Everything is back to normal after switching to uClibc. I guess it was that ILL_ACC kernel bug between r45710 and r45747, but I pulled just after the musl update in r45754, which seems to break a lot of other boards… such is life ;-) Thanks again, @jogo; go ahead, and close this report.

P.S. I had been using musl for many months, basically was forced to on these 4 MB boards after the great (e)glibc transition a while back… Anyway, I see that uClibc is default once again on ramips & ar71xx, and even slimmer than before.

Last edited 3 years ago by AndreiM (previous) (diff)

comment:8 Changed 3 years ago by jogo

  • Resolution set to fixed
  • Status changed from reopened to closed

Thanks for reporting back.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.