Modify

Opened 3 years ago

#19695 new defect

1-Wire on HLK-RM04

Reported by: renard.fabien@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: 1-wire, w1, rt5350, hlk-rm04 Cc:

Description

Hello, I tried to build OpenWrt in order to use 1-Wire on a HLK-RM04 module (Ralink RT5350 SoC) but never succeed.

I searched and did a bunch of tests to setup 1-wire on gpio0 (using kmod-w1, kmod-w1-gpio-custom, kmod-w1-slave-therm), but always got errors like:

unable to select pin group

or

[ 23.250000] w1-gpio w1-gpio.0: no of_node; not parsing pinctrl DT
[ 23.250000] w1-gpio w1-gpio.0: Failed to parse gpio property for data pin (-2)
[ 23.250000] w1-gpio: probe of w1-gpio.0 failed with error -2

I think the HLKRM04.dts have the wrong parameters and I don't know what to do ... I tried with the default .dts file, by freeing gpio or by adding the following section

w1-gpio {

compatible = "w1-gpio";
gpios = <&gpio0 0 1>;

};

I tried with Barrier Breaker (revision 42625) and Chaos Calmer rev 45xxx

Thanks

Attachments (0)

Change History (0)

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.