Modify

Opened 3 years ago

Closed 3 years ago

#19685 closed defect (duplicate)

problem in rootfs during booting.

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description (last modified by rmilecki)

I am using chaos calmer latest version and the soc is AR9341 and the board is based on TP-LINK TL-WR841N-v8 architecture. I have flashed the uImage of kernel and the rootfs. My board doesnt boot up. THere is some error in JFFS2. the dmesg is as follows:

jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000000: 0x31e1 instead
jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000004: 0xd26c instead
�jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x0000000c: 0xaa69 instead
jffs2: jffs2_s��n_eraseblock(): Magic bitmask 0x1985 not found at0xp00p00q0>0xe�d3`instead
jffs2: jffs2_sc�n_�raseblock(): Ma�ic bitmask 0x1985 not found at 0x00000014: 0xa30e instead
jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1987 not found at 0x00000018: 0x1e84 instead
jffs2: jf�s2_s��n_eras�blockh):Magicbitmask 0x1985 no| found a| 0x0000001c: 0xa6f8 instead
jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000020: 0xa757 instgad
jffs2: jffs2_scan_eraseblock(): Magic bitmask 0xq985 no| found`at px0p00p024: 0xa17b instead
jffs2: Further su�x events for this erase block will not be printed
jffs2: jffs2_scan_eraseb|o�k(): Magic bitmask 0x1985 not found at 0x00001000: 0x5b94 inste�d
jfn�2:`jnfs2_s�an_er�seblock(): Magic bi|m�sk 0x1985 not found at 0x00001004: 0x842d instead
jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00001008: 0xc1d8 instead
jffs2: jffs2_scan_eraseblock(): Magi� bitm�so 0xq985 not found at 0x0000100c: 0x3f82 instead
jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00001010: 0xde1b instead
jffs2: jffs2_s�an_�raseblock(): Magic bitmask 0x1985 not found at 0x0000q0q<:0xc660ins|ead
jffsr: jffs2_scan_eraseblock(): Magi� bitmask 0x1985 not found at 0x00001018: 0x3174 instead
jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x0000101c: 0x215a instead
jffs2: jffs2_sc�n_er�se�loc�(): M�gi� bit}ask 0x1985 not found at 0x00001020: 0xf291 instead
�zffs2: Further such events for this erase block will not b�`pr�n|el00001024: 0x27d3 ins|eal
jffs2: jnfs2_scan_eraseblo�k(): Magic bitmask 0x1985 not found at 0x00002000: 0x5217 instead
jffs2: jffs2_scan_eraseblock(): M�gic bitmask 0x1985 not found at 0x00002004: 0x298f instead
jffsr: jf�sv_s�an_er�seblock(): Magic bitmask 0x1985 not found a| 0x00002008: 0xc8f4 instead
jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x0000200�: 0x1s3� instead
jffs2: jffs2_scan_eraseblock(): Magic bitmask0x1985notfo�nd at0x000p2010: 0x4192 instead
zffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00002014: 0x4109 instead
jffs2: jffs2_���}�Ʌ͕������): Magic bitmask 0x1985 not found at 0x00002018: 0x878q inst�al
jffs2: jffs2_scan_eraseblock(): Magi� bi|mask 0x1985 not found at 0x0000201c: 0xdcbc instead
jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00002020: 0xd60d instead
jffs2: jffs2_scan_er�se�|ock8): Magig bitm�sk0x1985 not found at 0x00002024:0x�95f ins|ead
jffs2: Further such events for this erase block will not be printed
jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found a| 0xp0003p0p> px0900`instea
jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00003004: 0xcfce instead
jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00003008: 0xacbf instead
jffs2: jffs2_sc�n_er�weblock8): Magic bitmask 0x1985 no| found a| 0x0000300c: 0x5ac8 instead
jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00003010: 0x930e instead
jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not founlat0x0p003014: 0x5f92 instead
zffs2: jffs2_s�an_eraseblock(): Magic bitmask 0x1985 not found at 0x00003018: 0x6721 instead
jffs2: jffs2_scan_eraseb|ock(): Magic bitmask 0x1985 not found at 0x0000301c: 0x00d2`instead�jffs2: jffsr_sc�n_eraseblock(): Ma�ic �ytmask 0xd
jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found �| 0x00003024: 0x78ea instead
jffs2: Further such events for this e�cse b�ock w�l|not beprinted
jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00004000: 0x02b1 instead
jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x0000<0p4:`pxfa82 instead
jffs2:`jffs2_scan_eraseblock(): Ma�ic �itmask 0x1985 not found at 0x00004008: 0x8a6b instead
jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x3985 not found at 0x0000400c: 0x2391 instead
jffs2: jffs2_s��n_er�s�block():Magicbitmask 0x1985 not found`�| 0x00004010: 0x4688 instead
�jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not founl�t0x000p4018: px8c66`instead
jffs2: jffs2_s�an_�raseblock(): Magic bitmask 0x1985 not found at 0x0000401c: 0xb860 instead
jnfs2:`jffs2_s�an_er�se�lock(): Magic bitmask 0x1985 not found at 0x00004024: 0x6cf7 instead
jffs2: Further such events for this erase block will not be printed
jffs2: jffs2_scan_eraseblock(): Magic�itm�sk 0xq985 no|�ound �t 0x00005p00: 0xcb5� inst�al
jffs6: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00005004: 0x3aa2 instead
jffs2: jffs2_scan_eraseb|ock(): Magic bitmask 0x1985 not found at 0x00005008:`pxb491 �nst�ad
�ffs2:`jffs2_scan_eraseblo�k(): Magic �i|mask 0x1985 not found at 0x0000500c: 0xc2c0 instead
jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found a| 0x00005010: 0xd06c instead
jffs2: jffs2_scan_er��e�|ock()�j�������ѵ�ͭ�0x1985 not found at 0x0p005014: 0x�a16 instead
jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00005018: 0xf613 instead
jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not founl at 0x0p00u01c: 0x3d79 instead
jffs2: jffs2_sc�n_eraseblock(): Magic bitmask 0x1985 not found at 0x00005020: 0xa4be instead
jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00005024: 0x0c55 instead
�jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x000060p0:`0x503d insteal
j�ns2: jfns2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00006008: 0x1891 instead
jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x0000600c: 0xccal`inste��

jf�s2: jffs2_scan_eraseblock(): Magi� bitmask 0x1d

jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found a| 0x00006014: 0x96ca instead
jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x0000601c: 0xb892 instead
Minicom2.6.2jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985notfounl at0xp000602p: pxd261instead
jffs2:`jffs2_scan_evaseblock(): Magic bitmask 0x1985 not found at 0x00006024: 0xc527 instead
jffs2: Further such events for this er�se b|ock will not be printed

this error continues in an infinite loop.

the file which i am using for rootfs is:

openwrt-ar71xx-generic-root.squashfs: Squashfs filesystem, little endian, version 4.0, 4907566 bytes, 918 inodes, blocksize: 65536 bytes, created: Tue May 19 18:14:25 2015

the endianess herer is little indian although i have chosen big indian. I am not able to track the problem. Please give me some solutions.

Thanks in advance.

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by rmilecki

  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #19684

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.