Modify

Opened 3 years ago

Last modified 3 years ago

#19662 new defect

Encryption: WPA2 PSK (WEP-40, CCMP) What?

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: Cc:

Description

I think this is a display error triggered by my configuration.

Both iwinfo and LuCI will show Encryption: WPA2 PSK (WEP-40, CCMP) on the 5GHz band.

I also have the feeling that TX power display is somehow flipped (router is supposed to be 20dBm on 2.4GHz and 17dBm on 5GHz).

wlan0     ESSID: "xxx"
          Access Point: xx
          Mode: Master  Channel: xx
          Tx-Power: 17 dBm  Link Quality: 57/70
          Signal: -53 dBm  Noise: -92 dBm
          Bit Rate: 104.0 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: unknown [Generic MAC80211]
          TX power offset: unknown
          Frequency offset: unknown
          Supports VAPs: yes  PHY name: phy0

wlan0-1   ESSID: "guest"
          Access Point: xx
          Mode: Master  Channel: xx
          Tx-Power: 17 dBm  Link Quality: 70/70
          Signal: -3 dBm  Noise: -92 dBm
          Bit Rate: 54.0 MBit/s
          Encryption: WEP Open System (WEP-40)
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: unknown [Generic MAC80211]
          TX power offset: unknown
          Frequency offset: unknown
          Supports VAPs: yes  PHY name: phy0

wlan1     ESSID: "xxx"
          Access Point: xx
          Mode: Master  Channel: xx
          Tx-Power: 20 dBm  Link Quality: 49/70
          Signal: -61 dBm  Noise: -91 dBm
          Bit Rate: 364.5 MBit/s
          Encryption: WPA2 PSK (WEP-40, CCMP)
          Type: nl80211  HW Mode(s): 802.11an
          Hardware: 168C:0033 168C:A120 [Atheros AR9580]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1
config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/ar934x_wmac'
	option htmode 'HT40'
	option country 'xx'
	option channel 'xx'
	option txpower '20'

config wifi-iface
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'xxx'
	option encryption 'psk2+ccmp'
	option key 'xxx'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0'
	option channel 'xx'
	option htmode 'HT40'
	option country 'xx'
	option txpower '20'

config wifi-iface
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'xxx'
	option encryption 'psk2+ccmp'
	option key 'xxx'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option network 'dmz'
	option isolate '1'
	option ssid 'guest'
	option encryption 'wep-open'
	option key '1'
	option key1 's:guest'

Attachments (0)

Change History (7)

comment:1 Changed 3 years ago by anonymous

Please attach the contents of /var/run/hostapd-phy1.conf

comment:2 Changed 3 years ago by anonymous

root@xxx:/tmp/run# cat hostapd-phy1.conf 
driver=nl80211
logger_syslog=127
logger_syslog_level=2
logger_stdout=127
logger_stdout_level=2
country_code=xx
ieee80211d=1
ieee80211h=1
hw_mode=a
channel=xx

ieee80211n=1
ht_capab=[HT40-][LDPC][SHORT-GI-20][SHORT-GI-40][TX-STBC][RX-STBC1][DSSS_CCK-40]

interface=wlan1
ctrl_interface=/var/run/hostapd
disassoc_low_ack=1
preamble=1
wmm_enabled=1
ignore_broadcast_ssid=0
uapsd_advertisement_enabled=1
wpa_passphrase=xxx
auth_algs=1
wpa=2
wpa_pairwise=CCMP
ssid=xxx
bridge=br-lan
wpa_key_mgmt=WPA-PSK
okc=0
disable_pmksa_caching=1
bssid=xxx

comment:3 Changed 3 years ago by jow

What is the version of iwinfo as reported by opkg list-installed iwinfo ?

comment:4 Changed 3 years ago by anonymous

comment:5 Changed 3 years ago by jow

No luck so far with trying to reproduce it. Do you also see the misreported value if you issue iwinfo wlan1 info? Also can you attach the output of strace iwinfo?

comment:6 Changed 3 years ago by anonymous

This is strange..

root@xxx:~# iwinfo
wlan0     ESSID: "xxx"
          Access Point: xxx
          Mode: Master  Channel: xxxx
          Tx-Power: 17 dBm  Link Quality: 45/70
          Signal: -65 dBm  Noise: -91 dBm
          Bit Rate: 33.1 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: unknown [Generic MAC80211]
          TX power offset: unknown
          Frequency offset: unknown
          Supports VAPs: yes  PHY name: phy0

wlan0-1   ESSID: "guest"
          Access Point: xx
          Mode: Master  Channel: xx
          Tx-Power: 17 dBm  Link Quality: 61/70
          Signal: -49 dBm  Noise: -91 dBm
          Bit Rate: 54.0 MBit/s
          Encryption: WEP Open System (WEP-40)
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: unknown [Generic MAC80211]
          TX power offset: unknown
          Frequency offset: unknown
          Supports VAPs: yes  PHY name: phy0

wlan1     ESSID: "xxx"
          Access Point: xxx
          Mode: Master  xxx
          Tx-Power: 20 dBm  Link Quality: 47/70
          Signal: -63 dBm  Noise: -91 dBm
          Bit Rate: 405.0 MBit/s
          Encryption: WPA2 PSK (WEP-40, CCMP)
          Type: nl80211  HW Mode(s): 802.11an
          Hardware: 168C:0033 168C:A120 [Atheros AR9580]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1

root@xxx:~# iwinfo wlan1 info
wlan1     ESSID: "xxx"
          Access Point: xxx
          Mode: Master  Channel: xx
          Tx-Power: 20 dBm  Link Quality: 48/70
          Signal: -62 dBm  Noise: -91 dBm
          Bit Rate: 405.0 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11an
          Hardware: 168C:0033 168C:A120 [Atheros AR9580]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1

I dont have strace in my current build, I will have to add it, rebuild and report later on that one.

comment:7 Changed 3 years ago by jow

I tracked down the issue and will commit a fix soon.

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.