Modify

Opened 3 years ago

Closed 3 years ago

#19608 closed defect (duplicate)

sane reports hp 5590 continuously busy

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: sane, device busy, hp5590, Cc:

Description

Hi!

I installed sane on my tl-wdr4300 with Barrier Breaker for serving an HP 5590 that is directly supported by the sane backends. This scanner works fine on Debian with the same version number of sane and sane backends. OpenWRT recognises the scanner:

root@harad:~# lsusb
Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 005: ID 1058:1130 Western Digital Technologies, Inc.
Bus 001 Device 004: ID 03f0:1705 Hewlett-Packard ScanJet 5590
root@harad:~# sane-find-scanner

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.
  # Also you need support for SCSI Generic (sg) in your operating system.
  # If using Linux, try "modprobe sg".

found USB scanner (vendor=0x03f0 [Hewlett-Packard], product=0x1705 [hp scanjet scanner]) at libusb:001:004
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

but when I try to scan sane reports the scanner as busy:

root@harad:~# scanimage -L
[hp5590] hp5590_get_status: USB-in-USB: got non-zero device status (status 12)
[hp5590] hp5590_init_scanner: scanner reports non-zero status: Device busy

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

when enabling debug in sane it seems to recognize properly the scanner and communicates with it, but it says that the scanner is allways busy:

root@harad:~# scanimage -L
[sanei_debug] Setting debug level of hp5590 to 50.
[hp5590] SANE backed for HP ScanJet 4500C/4570C/5500C/5550C/5590/7650 1.0.7
[hp5590] (c) Ilia Sotnikov <hostcc@gmail.com>
[hp5590] attach_usb_device: Opening USB device
[hp5590] attach_usb_device: USB device opened
[hp5590] hp5590_init_scanner
[hp5590] hp5590_cmd: USB-in-USB: command : 0012
[hp5590] hp5590_control_msg: USB-in-USB: core data: no
[hp5590] hp5590_control_msg: USB-in-USB: sending control msg
[hp5590] hp5590_get_ack
[hp5590] hp5590_get_ack: USB-in-USB: accepted
[hp5590] hp5590_get_ack
[hp5590] hp5590_get_ack: USB-in-USB: accepted
[hp5590] hp5590_verify_last_cmd: USB-in-USB: command verification requested
[hp5590] hp5590_control_msg: USB-in-USB: core data: no
[hp5590] hp5590_control_msg: USB-in-USB: sending control msg
[hp5590] hp5590_get_ack
[hp5590] hp5590_get_ack: USB-in-USB: accepted
[hp5590] hp5590_get_ack
[hp5590] hp5590_get_ack: USB-in-USB: accepted
[hp5590] hp5590_verify_last_cmd: USB-in-USB: command verification 0012, last command: 0012, core status: 0000
[hp5590] hp5590_verify_last_cmd: USB-in-USB: command verified successfully
[hp5590] HP5590 flags (0x02)
[hp5590] HP5590 flags: ADF yes, TMA no, LCD no
[hp5590] HP5590 firmware version: 0.067
[hp5590] HP5590 max resolution X: 2400 DPI
[hp5590] HP5590 max resolution Y: 2400 DPI
[hp5590] HP5590 max pixels X: 20400
[hp5590] HP5590 max pixels Y: 28128
[hp5590] HP5590 max size X: 8.500 inches
[hp5590] HP5590 max size Y: 11.720 inches
[hp5590] HP5590 normal motor param: 100, max motor param: 1000
[hp5590] hp5590_get_status
[hp5590] hp5590_get_status: USB-in-USB: got non-zero device status (status 12)
[hp5590] hp5590_init_scanner: scanner reports non-zero status: Device busy
[hp5590] sane_hp5590_get_devices, local only: 0
[hp5590] Found 0 devices

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
[hp5590] sane_hp5590_exit

Contrary to /ticket/15381.html logread does not report any problem.

Any idea?

Thank you in advance
Javier

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by swalker

  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.