Modify

Opened 3 years ago

Last modified 3 years ago

#19602 assigned defect

Crash/softbrick when enabling IPv6/wan6 (@wan) on pppoe-wan in recent trunk

Reported by: anonymous Owned by: cyrus
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc: cyrus@…

Description

As title says, this has been going on for a while (a month?).

To make sure it wasn't my configuration I decided to to a fresh installation with a default configuration. Everything went well up until the point where I added the wan6 (@wan, dhcpc6) interface. I suspect some kind of routing loop brings it down. After power cycling it's pingable.. for a while, then it dies again.

Booting in safemode, doing mount_root and removing the @wan interface makes the device functional again.

I'm currently reverted to BB since I need IPv6 but in time (some week from now) I should be able to help testing/resolving this bug. Still I thought I'd leave this ticket here in case it's something obvious.

Hardware is TP-Link TL-WDR4300 v1.

Attachments (0)

Change History (6)

comment:1 Changed 3 years ago by cyrus

In trunk there is no need to add a wan6 interface for pppoe. Unless you explicitly set "option ipv6 0" in the pppoe section, IPv6 will be requested and the dhcpv6-client will be spawned if necessary.

comment:2 Changed 3 years ago by cyrus

  • Cc cyrus@… added
  • Owner changed from developers to cyrus
  • Status changed from new to assigned

Actually the behavior depends on the value of "option ipv6" in the pppoe-section.
If it is not set at all (no option ipv6) or if it is set to auto ("option ipv6 auto") IPv6 is requested and a dhcpv6-client is spawned even if no wan6-section is added to /etc/config/network.

If option ipv6 is set to 1 then only layer 2 of IPv6 is brought up and the wan6-section needs to be manually added for RA and DHCPv6 configuration. In any case please post your /etc/config/network

comment:3 Changed 3 years ago by anonymous

I've done some testing and what you're saying doesn't seem to be accurate (on revision 45674).

If I use LuCI for setting IPv6 on the pppoe-wan link it will either set option ipv6 to 0 or 1, not auto. I guess LuCI has not been adapted for this. Either way, setting it manually with uci to 0, 1 or auto, or even removing the setting all together will not spawn odhcp6c on the wan link. (Yes, I know how to use uci commit, etc.) :)

I'll try again to add a wan6 (@wan) adapter and see what happens, but from previous experience it will probably need a soft reset. I'll report later. Also considering this, an upgrade BB -> CC would cause quite a few configurations to be semi-bricked, if this is a common occurence. Right?

Anyway, thanks for helping!

/etc/config/network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fxxx:xxxx:xxxx::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '172.x.x.1'
        option ip6assign '64'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2 3 4 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1'

config interface 'wan'
        option proto 'pppoe'
        option ifname 'eth0.2'
        option username 'secret'
        option password 'moresecret'

comment:4 Changed 3 years ago by anonymous

Curiously, if I run odhcp6c manually, it appears to request and get a response, but doesn't set any IPv6-prefixes or addresses.

root@kirk:/lib/netifd# odhcp6c -e -v pppoe-wan
odhcp6c[6346]: (re)starting transaction on pppoe-wan
odhcp6c[6346]: Starting SOLICIT transaction (timeout 4294967295s, max rc 0)
odhcp6c[6346]: Got a valid reply after 20ms
odhcp6c[6346]: Starting REQUEST transaction (timeout 4294967295s, max rc 10)
odhcp6c[6346]: Send REQUEST message (elapsed 0ms, rc 0)
odhcp6c[6346]: Got a valid reply after 18ms
odhcp6c[6346]: entering stateful-mode on pppoe-wan
odhcp6c[6346]: Starting <POLL> transaction (timeout 21600s, max rc 0)

Perhaps I'm misunderstanding how the client works though, never used it manually before.. anyway I'll keep testing.

comment:5 Changed 3 years ago by anonymous

Somehow I now got it to work with the wan6 (@wan) interface set as dhcpv6 (option ipv6 set to 1).

I failed to get it to work without this pseudo-interface though.

comment:6 Changed 3 years ago by anonymous

I just tried this all again on r45770 and having option ipv6 'auto' still doesnt automatically set up IPv6 on the wan interface (pppoe).

I can see IPv6 being available in the logs:

Tue May 26 18:56:48 2015 daemon.notice pppd[3742]: local  LL address fe80::x:x:x:x
Tue May 26 18:56:48 2015 daemon.notice pppd[3742]: remote LL address fe80::x:x:x:x

Things seem to work fine with manual wan6 (@wan) link though.

Am I missing something?

Add Comment

Modify Ticket

Action
as assigned .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.