Modify

Opened 3 years ago

Last modified 3 years ago

#19565 new defect

LuCi cannot set operating frequency after changing default LAN IP

Reported by: Tki2000 Owned by:
Priority: normal Milestone: Chaos Calmer 15.05
Component: luci Version: Trunk
Keywords: wifi operating frequency Cc:

Description

LuCi can only set the default mode/band/channel/width when IP is 192.168.1.1
After setting the router LAN IP to 192.168.6.1 LuCi cannot determine the correct settings to adjust, so trying to modify these setting in LuCi will end in nonworking wifi settings saved to /etc/config/wireless. The setting are not shown neither for ac radio, nor bgn one.

If the router is set to 192.168.1.1, the settings are visible again in LuCi, and I can set both, the ac and bgn frequencies.

Router: Sitecom X8 WLR-8100

"Powered by LuCI Master (git-15.090.50849-576e235) / OpenWrt Chaos Calmer r45337"

I have attached two files where this effect can be seen. The empty "select boxes" correspond to the router when having IP 192.168.6.1. The good one correspond to the same router when having IP 192.168.1.1.

Attachments (3)

Sitecom-X8 - Wifi - LuCI - 192.168.6.1.png (47.2 KB) - added by Tki2000 3 years ago.
Sitecom-X8 - Wifi - LuCI - 192.168.6.1
Sitecom-X8 - Wifi - LuCI - 192.168.1.1.png (49.1 KB) - added by Tki2000 3 years ago.
Sitecom-X8 - Wifi - LuCI - 192.168.1.1
LuCi - Operating Frequency.zip (91.8 KB) - added by Tki2000 3 years ago.

Download all attachments as: .zip

Change History (6)

Changed 3 years ago by Tki2000

Sitecom-X8 - Wifi - LuCI - 192.168.6.1

Changed 3 years ago by Tki2000

Sitecom-X8 - Wifi - LuCI - 192.168.1.1

comment:1 Changed 3 years ago by jow

I cannot really reproduce that behaviour. Any javascript errors reported by your browser? Can you attach the source view of the page if the boxes are empty?

comment:2 Changed 3 years ago by Tki2000

I leave here a zip with several sources.

HTML_source_192.168.x.1.html are the sources as seen with CRTL+U in Firefox.
Sitecom-X8 - Wifi - LuCI.htm , as saved with "save as" in Firefox.
Sitecom-X8 - Wifi - LuCI - BAD.htm , as saved with "save as" in Firefox.

Only Sitecom-X8 - Wifi - LuCI.htm option boxes are populated.

No javascript errors appear, neither in Firefox, nor in IE.

Changed 3 years ago by Tki2000

comment:3 Changed 3 years ago by Tki2000

Sorry, I have to post some news.
After pressing reload in Firefox, the select boxes have been populated with the correct values, so some kind of cache may have interferred. Firefox is now working OK.

But I cannot get IE8 to work. It does not populate values even with 192.168.1.1. I get the following errors (I have missed them before). Sorry they are in spanish.

Detalles de error de página web

Agente de usuario: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E)
Fecha: Mon, 27 Apr 2015 15:46:46 UTC


Mensaje: Argumento no válido.
Línea: 321
Carácter: 4
Código: 0
URI: http://192.168.6.1/cgi-bin/luci/;stok=85f4d3a48e76ba80157fc339df6f9891/admin/network/wireless/radio0.network1


Mensaje: No se puede mover el foco hacia el control porque el control es invisible, no está habilitado o es de un tipo que no acepta al foco.
Línea: 509
Carácter: 2
Código: 0
URI: http://192.168.6.1/luci-static/resources/cbi.js


Mensaje: Se esperaba un objeto
Línea: 993
Carácter: 5
Código: 0
URI: http://192.168.6.1/luci-static/resources/cbi.js


Mensaje: No se puede mover el foco hacia el control porque el control es invisible, no está habilitado o es de un tipo que no acepta al foco.
Línea: 509
Carácter: 2
Código: 0
URI: http://192.168.6.1/luci-static/resources/cbi.js

Anyway, I do not care about IE.
If you feel that there's an issue with IE, then try to fix whenever you may wish.
If not, then as Firefox is working, please close this ticket.

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.