Modify

Opened 3 years ago

Closed 2 years ago

Last modified 21 months ago

#19563 closed defect (fixed)

Luci not working anymore in trunk

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

I did a sysupgrade to r45579 and luci isnt working anymore in the newest trunk, it was still working in my last build which is about 2 months old. When I login into Luci it just shows "collecting data" or a "-" at every point where it should load any data from the system. I dont see anything special in the logs.

Attachments (2)

2015-07-16_03 collecting data-delay.png (93.0 KB) - added by gvalkov 3 years ago.
2015-07-16_03 collecting data-delay
2015-07-16_04 collecting data-delay.png (97.8 KB) - added by gvalkov 3 years ago.
2015-07-16_04 collecting data-delay

Download all attachments as: .zip

Change History (10)

comment:1 Changed 3 years ago by anonymous

Weird but it seemes to be a problem with my Chrome, it works in IE11. I tried to delete Chrome's cache without any luck. But it worked before the sysupgrade. Ill try to reinstall Chrome.

comment:2 Changed 3 years ago by anonymous

Ok not working anymore too now with IE, it's definitely some weird bug by Luci/OpenWRT.

Changed 3 years ago by gvalkov

2015-07-16_03 collecting data-delay

Changed 3 years ago by gvalkov

2015-07-16_04 collecting data-delay

comment:3 Changed 3 years ago by gvalkov

I have reproduced this on r46314. I can also confirm that r41950 worked properly.
The truth is somewhere in between. Tested on TP-LINK WR1043ND v1 and v2.

It seems to appear random: If there is no delay after the reboot, it will work nice and smooth until the next restart or power off. If there is a delay, it will delay every time a page is loaded until restart. The delay is around 22 seconds and then the data is shown.

I am certain this is not related to configuration either, because I have preset configuration on the images I compile. After hitting the Reset to default button or re-flashing the same image, I get the same random behaviour.

comment:4 follow-up: Changed 2 years ago by bolvan

r47238

can login only in mozilla browser
cannot in IE11 and Chromium. redirects to starting page.

when using openwrt theme fatal error in tab System-software

<a onclick="window.confirm('Remove &quot;6in4&quot; ?') && this.parentNode.submit(); return false" href="#">Remove</a> -----------------------------------------------------------------------------------------------------------------

2fix I had to edit
/usr/lib/lua/luci/view/themes/openwrt.org/header.html
and remove <?xml and change content type to "text/html"

Last edited 2 years ago by bolvan (previous) (diff)

comment:5 in reply to: ↑ 4 Changed 2 years ago by anonymous

Replying to bolvan:

r47238
...
2fix I had to edit
/usr/lib/lua/luci/view/themes/openwrt.org/header.html
and remove <?xml and change content type to "text/html"

Bootstrap is the current default theme.
The old openwrt.org theme is probably somewhat unsupported.

comment:6 Changed 2 years ago by bolvan

OK. I fixed openwrt theme myself.
But login problem still exist.
I looked up what firefox, IE and chrome send after pressing "Login".
Login form is submitted in POST request.
Return code is 302 Redirected, and sysauth cookie is set in response headers.
Then browser GET redirected location.
Firefox send "sysauth" cookie back and login proceeds.
Others do not send any cookies and http code is 403 Forbidden

Looks like only firefox accept that cookie.

Last edited 2 years ago by bolvan (previous) (diff)

comment:7 Changed 2 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

comment:8 Changed 21 months ago by anonymous

just a additional note:

had a similar issue that all browsers stuck at "collecting data" on windows 7

turned out that oracle virtualbox had somekind of issue - took me 3 months.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.