Modify

Opened 11 years ago

Closed 11 years ago

Last modified 4 years ago

#1949 closed defect (fixed)

Madwifi no_tpc doesn't actually turn off TPC

Reported by: jhansen@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version:
Keywords: madwifi tpc Cc:

Description

In order to properly disable TPC, you need to set ATH_CAP_TPC=0 in BuildCaps.inc.

Also, I don't see any performance problems with TPC as long as you set the txpower after starting the AP VAP (a valid txpower in the wireless config is required). With TPC enabled, the default txpower is set to 0 (go figure), so you have to set it manually.

Attachments (2)

504-no_tpc.patch (238 bytes) - added by jhansen@… 11 years ago.
Disable TPC
tpc-final.patch (2.8 KB) - added by jhansen@… 11 years ago.
Automatic TPC selection final patch (hopefully)

Download all attachments as: .zip

Change History (14)

Changed 11 years ago by jhansen@…

Disable TPC

comment:1 Changed 11 years ago by jhansen@…

You can also check the value of tpc before calling ath_hal_setcapability (line ~1842 of if_ath.c).

comment:2 Changed 11 years ago by nbd

how do you think the txpower=0 problem should be fixed?

comment:3 Changed 11 years ago by jhansen@…

For the short term (for AP mode at least), you can select a channel, bring up the interface, wait a second, then keep pinging the txpower higher and higher, and it will stick at whatever the highest txpower supported is. It would be nice if you could query the driver somehow as to what the maximum txpower for a specific channel, but until then, this is a good quick fix:

iwconfig ath0 channel 1
ifconfig ath0 up
sleep 1
iwconfig ath0 txpower 15 # may not need to start this low, but...
iwconfig ath0 txpower 16
iwconfig ath0 txpower 17
iwconfig ath0 txpower 18
iwconfig ath0 txpower 19
iwconfig ath0 txpower 20
iwconfig ath0 txpower 21

comment:4 Changed 11 years ago by jhansen@…

A good "&> /dev/null" on each txpower line would be nice also, to keep iwconfig quiet when it fails.

comment:5 Changed 11 years ago by nbd

I'd like a cleaner solution than that :)
Normally the driver should figure out the txpower itself. The problem is that it fails to query the power from the HAL properly.

comment:6 Changed 11 years ago by nbd

should be fixed in [7929], please verify

Changed 11 years ago by jhansen@…

Automatic TPC selection final patch (hopefully)

comment:7 Changed 11 years ago by jhansen@…

Attached tpc patch with finishing touches (note that the patch isn't displaying correctly in trac, make sure you download the original).

comment:8 Changed 11 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

added in [7947], thanks.

comment:9 Changed 11 years ago by jhansen@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

The complete tpc-final.patch was not committed. Without a couple of the extra modifications (to if_ath.c), the desired, or previous, txpower is forgotten if a channel change is made to a channel with a lower txpower. For example:

# iwconfig ath0 channel 6
# ifconfig ath0 up
# iwconfig ath0
(... iwconfig shows txpower of 18 ...)
# iwconfig ath0 channel 1
(... iwconfig shows txpower of 17 ...)
# iwconfig ath0 channel 6
(... iwconfig shows txpower of 17 ...)

The extra changes make it so that a switch back to 6 would set the txpower to 18, like it should. Trac was not showing the patch correctly, so you'll need to "download the original" when viewing the patch to get the last changes.

comment:10 Changed 11 years ago by nbd

whoops. sorry. forgot your comment about the broken display in trac. will fix it later today.

comment:11 Changed 11 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

fixed in [7948]

comment:12 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.