Modify

Opened 3 years ago

Closed 3 years ago

#19428 closed defect (moved_to_github)

Sshtunnel cannot start in dynamic mode

Reported by: wittywang@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: sshtunnel Cc:

Description

When trying to start sshtunnel in ssh dynamic mode (tunnelD), the service can not start with an error message of "sh: bad number".

I tried to trace into /etc/init.d/sshtunnel, and find this error was caused by line 69 as below:

[ "$remoteport" -gt 0 ]
append_string "error" "[tunnelD: $1]remoteport must be a positive integer" "; "

In dynamic mode, no port number is passed to $remoteport, and this cause the error. After remarking this line, it works fine.

Can someone help to currect this error in source code? Thank you.

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by nbd

  • Resolution set to moved_to_github
  • Status changed from new to closed

sshtunnel is maintained here: https://github.com/openwrt/packages

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.