Modify

Opened 3 years ago

Closed 3 years ago

#19426 closed defect (fixed)

TLWDR4300 Sysupgrade and factory binaries are swapped

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: Cc:

Description

In the trunk download-tree it appears that all targets with profile TLWDR4300 have the wrong filenames. *Sysupgrade.bin are 8MB and *factory.bin are around 3MB. Same thing happens with the image generator. Affected files are for TP-LINK TL-WDR3500/3600/4300/4310/MW4350R.

https://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/

openwrt-ar71xx-generic-tl-wdr3600-v1-squashfs-factory.bin 06-Apr-2015 10:30 3211268
openwrt-ar71xx-generic-tl-wdr3600-v1-squashfs-sysupgrade.bin 06-Apr-2015 10:30 8126464

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by anonymous

Indeed this issue has come up since several days.

Please note that this ticket is a duplicate of #19400

comment:2 Changed 3 years ago by hnyman

It is probably due to r44998 and r45000, which defined "new build code" for just those TP-link devices.

r44998 looks strange, as it sets "factory" to have padding stripped from the end, while sysupgrade keeps the padding. Most likely the "-s" should be changed to the sysupgrade line.

# -s strip padding from end of the image 
...
                $(if $(findstring sysupgrade,$1),-j -X 0x40000) \ 
                $(if $(findstring factory,$1),-j -X 0x40000 -s) \ 

comment:3 Changed 3 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r45281

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.