Modify

Opened 3 years ago

Last modified 2 years ago

#19419 reopened defect

uhttpd spamming the log..

Reported by: daniel.petre Owned by:
Priority: normal Milestone: Chaos Calmer 15.05
Component: luci Version: Trunk
Keywords: uhttpd, luci, uci, logread Cc:

Description

Hello,
using trunk r45267 and uhttpd keeps spamming the log with:

Sat Apr 4 18:06:12 2015 daemon.err uhttpd[1829]: uci: Entry not found
Sat Apr 4 18:06:17 2015 daemon.err uhttpd[1829]: uci: Entry not found
Sat Apr 4 18:06:28 2015 daemon.err uhttpd[1829]: uci: Entry not found
Sat Apr 4 18:06:33 2015 daemon.err uhttpd[1829]: uci: Entry not found
Sat Apr 4 18:06:38 2015 daemon.err uhttpd[1829]: uci: Entry not found
Sat Apr 4 18:06:44 2015 daemon.err uhttpd[1829]: uci: Entry not found
Sat Apr 4 18:06:53 2015 daemon.err uhttpd[1829]: uci: Entry not found
Sat Apr 4 18:07:03 2015 daemon.err uhttpd[1829]: uci: Entry not found
Sat Apr 4 18:07:13 2015 daemon.err uhttpd[1829]: uci: Entry not found
Sat Apr 4 18:07:22 2015 daemon.err uhttpd[1829]: uci: Entry not found
Sat Apr 4 18:07:30 2015 daemon.err uhttpd[1829]: uci: Entry not found
Sat Apr 4 18:07:39 2015 daemon.err uhttpd[1829]: uci: Entry not found

Any ideas please?

Attachments (0)

Change History (12)

comment:1 Changed 3 years ago by anonymous

one (wild guess) is that this might be related (code regression?) to tickets:
#9750
#11426
#13398

comment:2 Changed 3 years ago by chris5560

Hi Daniel,
is the logging happen without started LuCI application or any other http/https connection to uhttpd ?
If not try to find out which LuCI screen/app is producing the log entrys.

comment:3 Changed 3 years ago by anonymous

I see this too.

Sun Apr 5 18:08:28 2015 daemon.err uhttpd[1868]: cat: can't open '/var/run/ddns/lucihelper.err': No such file or directory
Sun Apr 5 18:15:06 2015 daemon.err uhttpd[1868]: uci: Entry not found
Sun Apr 5 18:15:06 2015 daemon.err uhttpd[1868]: uci: Entry not found

comment:4 Changed 3 years ago by chris5560

Found the problem with the "cat" which should be fixed by editing
line 8 + 9 of /usr/lib/ddns/dynamic_dns_lucihelper.sh
insert ".$$" as shown below.
DATFILE="$RUNDIR/$SECTION_ID.$$.dat"
ERRFILE="$RUNDIR/$SECTION_ID.$$.err"

Did you only get uci error when "looking" at Dynamic DNS Application
I never got uci errors from uhttpd, whatever app I used.
To test if ddns-scripts is the problem, please call the following from console:

#> /etc/init.d/ddns disable
#> /etc/init.d/ddns stop
#> mv /etc/config/ddns /etc/config/ddns.bak

If you restart LuCI you will get an empty "Overview" of Dynamic DNS application.
Are the uci erros still there ???
To reactivate your your configuration do

#> mv -f /etc/config/ddns.bak /etc/config/ddns
#> /etc/init.d/ddns enable
#> /etc/init.d/ddns start

comment:5 Changed 3 years ago by daniel.petre

Sorry for the slow response: i only see the spam when looking at the main overview page in luci..

comment:6 Changed 3 years ago by chris5560

On Status-Overview are there other Applications showing their status ?
Please give me a list of files installed in:

/usr/lib/lua/luci/view/admin_status/index

directory.

comment:7 Changed 3 years ago by anonymous

Chris,

I edited

/usr/lib/ddns/dynamic_dns_lucihelper.sh

as you suggest, above, this fixes the problem for me. No doubt, Daniel will report.

Thank you very much.

comment:8 Changed 3 years ago by nbd

  • Resolution set to moved_to_github
  • Status changed from new to closed

ddns-scripts is maintained here: https://github.com/openwrt/packages

comment:9 Changed 2 years ago by anonymous

  • Resolution moved_to_github deleted
  • Status changed from closed to reopened

same problem, but not related to ddns-scripts as it is not even installed r47929

Sun Dec 20 13:23:23 2015 daemon.err uhttpd[2379]: uci: Entry not found
Sun Dec 20 13:23:23 2015 daemon.err uhttpd[2379]: uci: Entry not found
Sun Dec 20 13:23:23 2015 daemon.err uhttpd[2379]: uci: Entry not found
Sun Dec 20 13:23:28 2015 daemon.err uhttpd[2379]: uci: Entry not found
Sun Dec 20 13:23:28 2015 daemon.err uhttpd[2379]: uci: Entry not found
Sun Dec 20 13:23:28 2015 daemon.err uhttpd[2379]: uci: Entry not found
Sun Dec 20 13:23:33 2015 daemon.err uhttpd[2379]: uci: Entry not found
Sun Dec 20 13:23:33 2015 daemon.err uhttpd[2379]: uci: Entry not found
Sun Dec 20 13:23:33 2015 daemon.err uhttpd[2379]: uci: Entry not found
Sun Dec 20 13:23:38 2015 daemon.err uhttpd[2379]: uci: Entry not found
Sun Dec 20 13:23:38 2015 daemon.err uhttpd[2379]: uci: Entry not found
Sun Dec 20 13:23:38 2015 daemon.err uhttpd[2379]: uci: Entry not found
Sun Dec 20 13:23:43 2015 daemon.err uhttpd[2379]: uci: Entry not found
Sun Dec 20 13:23:43 2015 daemon.err uhttpd[2379]: uci: Entry not found
Sun Dec 20 13:23:43 2015 daemon.err uhttpd[2379]: uci: Entry not found
Sun Dec 20 13:23:48 2015 daemon.err uhttpd[2379]: uci: Entry not found
Sun Dec 20 13:23:48 2015 daemon.err uhttpd[2379]: uci: Entry not found
Sun Dec 20 13:23:48 2015 daemon.err uhttpd[2379]: uci: Entry not found
Sun Dec 20 13:23:53 2015 daemon.err uhttpd[2379]: uci: Entry not found
Sun Dec 20 13:23:53 2015 daemon.err uhttpd[2379]: uci: Entry not found
Sun Dec 20 13:23:53 2015 daemon.err uhttpd[2379]: uci: Entry not found
Sun Dec 20 13:23:55 2015 daemon.err uhttpd[2379]: sed: write error

comment:10 Changed 2 years ago by anonymous

Tue Dec 22 14:08:37 2015 daemon.err uhttpd[2214]: uci: Entry not found
Tue Dec 22 14:08:37 2015 daemon.err uhttpd[2214]: uci: Entry not found
Tue Dec 22 14:08:42 2015 daemon.err uhttpd[2214]: uci: Entry not found
Tue Dec 22 14:08:42 2015 daemon.err uhttpd[2214]: uci: Entry not found
Tue Dec 22 14:08:47 2015 daemon.err uhttpd[2214]: uci: Entry not found
Tue Dec 22 14:08:47 2015 daemon.err uhttpd[2214]: uci: Entry not found
Tue Dec 22 14:08:52 2015 daemon.err uhttpd[2214]: uci: Entry not found
Tue Dec 22 14:08:52 2015 daemon.err uhttpd[2214]: uci: Entry not found
Tue Dec 22 14:08:57 2015 daemon.err uhttpd[2214]: uci: Entry not found
Tue Dec 22 14:08:57 2015 daemon.err uhttpd[2214]: uci: Entry not found

comment:11 follow-up: Changed 2 years ago by anonymous

this caused by mwan3-luci and only on main page. the number of mwan3 configured interfaces equals to number of messages each 5 seconds.

comment:12 in reply to: ↑ 11 Changed 2 years ago by anon2

Replying to anonymous:

this caused by mwan3-luci and only on main page. the number of mwan3 configured interfaces equals to number of messages each 5 seconds.

In that case please file a bug at the Github packages repo where mwan3 resides.
https://github.com/openwrt/packages/issues
(And cc your issue report to the mwan3 package maintainer, @Adze1502 )

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.