Modify

Opened 3 years ago

Last modified 3 years ago

#19400 new defect

Erroneous build for ar71xx for tp-link tl-wdr3500 v1

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: Cc:

Description

  • factory is less in size, than sysupgrade
  • sysupgrade sized as flash - 8G
  • flashed system (both - factory and sysupgrade) boots (asterisk led stops blinking), but does not answer on any IP

Attachments (0)

Change History (4)

comment:1 Changed 3 years ago by anonymous

This issue starts at tl-wdr3500-v1 and continues down to tl-wdr4310-v1.

comment:2 Changed 3 years ago by anonymous

Indeed, the image sizes seem strange, compared to some weeks ago:

comment:3 Changed 3 years ago by hnyman

It is probably due to r44998 and r45000, which defined "new build code" for just those TP-link devices.

r44998 looks strange, as it sets "factory" to have padding stripped from the end, while sysupgrade keeps the padding. Most likely the "-s" should be changed to the sysupgrade line.

# -s strip padding from end of the image 
...
                $(if $(findstring sysupgrade,$1),-j -X 0x40000) \ 
                $(if $(findstring factory,$1),-j -X 0x40000 -s) \ 

comment:4 Changed 3 years ago by nbd

should be fixed in r45281, please test

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.