Modify

Opened 12 years ago

Closed 12 years ago

#194 closed defect (worksforme)

build fails when a few kernel modules is selected

Reported by: anonymous Owned by: developers
Priority: low Milestone:
Component: base system Version: 2.0
Keywords: Cc: vanekt@…

Description

kamikaze r2864

make menuconfig
select brcm 2.6
unselect all kernel modules

make

make[6]: Entering directory `/m/linux/usr/src/openwrt-hd/target/linux/linux-2.6'
rm -rf /m/linux/usr/src/openwrt-hd/build_mipsel/linux-2.6-brcm/linux-modules/ipkg/atm
/m/linux/usr/src/openwrt-hd/scripts/make-ipkg-dir.sh /m/linux/usr/src/openwrt-hd/build_mipsel/linux-2.6-brcm/linux-modules/ipkg/atm ../control/kmod-atm.control 2.6.15-brcm-1 mipsel
echo "Depends: kernel (2.6.15-brcm-1) " >> /m/linux/usr/src/openwrt-hd/build_mipsel/linux-2.6-brcm/linux-modules/ipkg/atm/CONTROL/control
mkdir -p /m/linux/usr/src/openwrt-hd/build_mipsel/linux-2.6-brcm/linux-modules/ipkg/atm/lib/modules/2.6.15
cp  /m/linux/usr/src/openwrt-hd/build_mipsel/linux-2.6-brcm/modules/lib/modules/2.6.15/kernel/net/atm/atm.ko /m/linux/usr/src/openwrt-hd/build_mipsel/linux-2.6-brcm/modules/lib/modules/2.6.15/kernel/net/atm/br2684.ko /m/linux/usr/src/openwrt-hd/build_mipsel/linux-2.6-brcm/modules/lib/modules/2.6.15/kernel/drivers/atm/atmtcp.ko  /m/linux/usr/src/openwrt-hd/build_mipsel/linux-2.6-brcm/linux-modules/ipkg/atm/lib/modules/2.6.15
mkdir -p /m/linux/usr/src/openwrt-hd/build_mipsel/linux-2.6-brcm/linux-modules/ipkg/atm/etc/modules.d
for module in atm; do echo $module >> /m/linux/usr/src/openwrt-hd/build_mipsel/linux-2.6-brcm/linux-modules/ipkg/atm/etc/modules.d/50-atm; done
PATH="/m/linux/usr/src/openwrt-hd/staging_dir_mipsel/usr/bin:/m/linux/usr/src/openwrt-hd/staging_dir_mipsel/bin:/bin:/sbin:/usr/bin:/usr/sbin" ipkg-build -c -o root -g root /m/linux/usr/src/openwrt-hd/build_mipsel/linux-2.6-brcm/linux-modules/ipkg/atm /m/linux/usr/src/openwrt-hd/bin/packages
mkdir: cannot create directory `/m/linux/usr/src/openwrt-hd/bin/packages/IPKG_BUILD.5577': No such file or directory
make[6]: *** [/m/linux/usr/src/openwrt-hd/bin/packages/kmod-atm_2.6.15-brcm-1_mi

[vanekt@big openwrt-hd]$ ls bin
ls: bin: No such file or directory

Same problem when iptables and diag kmods are selected.

Attachments (0)

Change History (1)

comment:1 Changed 12 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

Can't reproduce this...

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.