Modify

Opened 3 years ago

Closed 3 years ago

#19312 closed defect (fixed)

wget uses zlib but its opkg does not depend on it

Reported by: jsanwrt@… Owned by: developers
Priority: normal Milestone:
Component: packages Version: Barrier Breaker 14.07
Keywords: Cc:

Description

The wget package requires libz (zlib package), but it does not depend on it.

If you install wget, now you cannot fetch zlib even if you knew -- because opkg uses wget, and wget now does not work. You could work around this by removing the wget package to get busybox back.

% head -n 7 /etc/banner | tail -n 1

BARRIER BREAKER (14.07, r42625)

% opkg list-installed | grep zlib | wc -l
0
% opkg update
% opkg install wget
% wget
wget: can't load library 'libz.so.1'
% opkg install zlib
[fails because wget now is broken]

Attachments (0)

Change History (2)

comment:2 Changed 3 years ago by blogic

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.