Modify

Opened 3 years ago

Closed 3 years ago

#19235 closed defect (no_response)

kernel oops: __kfree_skb+0x14/0xd0

Reported by: christian@… Owned by: developers
Priority: normal Milestone:
Component: kernel Version: Trunk
Keywords: Cc:

Description

$ cat /tmp/sysinfo/model 
TP-Link Archer C5 v1

$ uname -a
Linux foobar 3.18.9 #3 Fri Mar 20 17:03:33 CET 2015 mips GNU/Linux
CHAOS CALMER (Bleeding Edge, r44902)
[   53.320000] Kernel bug detected[#1]:
[   53.320000] CPU: 0 PID: 1192 Comm: netifd Not tainted 3.18.9 #2
[   53.320000] task: 86c04e88 ti: 8699e000 task.ti: 8699e000
[   53.320000] $ 0   : 00000000 00000001 810dce00 00000001
[   53.320000] $ 4   : 00000000 80140524 86e70000 00000000
[   53.320000] $ 8   : 00000000 ffffff00 644add00 00000000
[   53.320000] $12   : 6e4a22ff 00000000 00000000 0a00ffff
[   53.320000] $16   : 8597dd80 00000000 00000001 86f5a000
[   53.320000] $20   : 00000000 00000800 80369150 80369148
[   53.320000] $24   : 00000000 8018dc98                  
[   53.320000] $28   : 8699e000 8699fbb8 00000000 8009eaa8
[   53.320000] Hi    : 00000767
[   53.320000] Lo    : 38954800
[   53.320000] epc   : 801b5c64 kfree+0x64/0x11c
[   53.320000]     Not tainted
[   53.320000] ra    : 8009eaa8 __kfree_skb+0x14/0xd0
[   53.320000] Status: 1100fc03 KERNEL EXL IE 
[   53.320000] Cause : 00800034
[   53.320000] PrId  : 00019750 (MIPS 74Kc)
[   53.320000] Modules linked in: iptable_nat ath9k nf_nat_ipv4 nf_conntrack_netlink nf_conntrack_ipv6 nf_conntrack_ipv4 ipt_REJECT ipt_MASQUERADE ebtable_nat ebtable_filter ebtable_broute ath9k_common xt_time xt_tcpudp xt_tcpmss xt_statistic xt_state xt_quota xt_policy xt_pkttype xt_physdev xt_owner xt_nat xt_multiport xt_mark xt_mac xt_limit xt_length xt_id xt_hl xt_esp xt_ecn xt_dscp xt_conntrack xt_comment xt_addrtype xt_TCPMSS xt_REDIRECT xt_LOG xt_HL xt_DSCP xt_CT xt_CLASSIFY rfcomm nfnetlink nf_reject_ipv4 nf_nat_masquerade_ipv4 nf_nat nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack iptable_raw iptable_mangle iptable_filter ipt_ah ipt_ECN ip_tables hidp hci_uart ebtables ebt_vlan ebt_stp ebt_snat ebt_redirect ebt_pkttype ebt_mark_m ebt_mark ebt_limit ebt_ip ebt_dnat ebt_arpreply ebt_arp ebt_among ebt_802_3 crc_ccitt btusb bnep bluetooth ath9k_hw em_cmp em_nbyte sch_dsmark em_meta sch_gred sch_htb sch_teql act_ipt sch_red sch_codel act_police em_text sch_tbf sch_sfq cls_basic sch_prio act_skbedit act_mirred em_u32 cls_u32 cls_tcindex cls_flow cls_route cls_fw sch_hfsc sch_ingress hid evdev input_core ath10k_pci ath10k_core ath mac80211 cfg80211 compat ledtrig_usbdev ledtrig_gpio batman_adv libcrc32c crc16 ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 nf_log_common ip6table_raw ip6table_mangle ip6table_filter ip6_tables x_tables ipcomp6 xfrm6_tunnel xfrm6_mode_tunnel xfrm6_mode_transport xfrm6_mode_beet esp6 ah6 ipcomp xfrm4_tunnel xfrm4_mode_tunnel xfrm4_mode_transport xfrm4_mode_beet esp4 ah4 tunnel6 tunnel4 af_key xfrm_user xfrm_ipcomp xfrm_algo ipv6 chainiv eseqiv crypto_wq sha1_generic krng rng md5 hmac des_generic deflate zlib_inflate zlib_deflate cbc authenc aead arc4 crypto_blkcipher ledtrig_transient ehci_pci ehci_platform ehci_hcd gpio_button_hotplug usbcore nls_base usb_common crc32c_generic crypto_hash
[   53.320000] Process netifd (pid: 1192, threadinfo=8699e000, task=86c04e88, tls=77eb0750)
[   53.320000] Stack : 00000000 00000800 80369150 80369148 8597dd80 8018de4c 00000000 801953cc
          8036aff4 00000000 0a000135 80195304 86f5a000 80000000 0002a548 8036913c
          8036a548 8036913c 8597dd80 800a3d30 8699fcd8 86adc800 80370000 80369148
          80369150 800f4280 8036aff4 802bb7c4 8597dd80 86e70046 86a62600 86e70046
          8699fcd8 86adc800 80370000 80369148 800ed51c 800ed7d4 8597dd80 00000000
          ...
[   53.320000] Call Trace:
[   53.320000] [<801b5c64>] kfree+0x64/0x11c
[   53.320000] [<8009eaa8>] __kfree_skb+0x14/0xd0
[   53.320000] [<8018de4c>] ip_error+0x1b4/0x1d0
[   53.320000] [<800a3d30>] __netif_receive_skb_core+0x630/0x6b0
[   53.320000] [<800ed7d4>] br_handle_frame+0x2b8/0x3f0
[   53.320000] [<800a3bbc>] __netif_receive_skb_core+0x4bc/0x6b0
[   53.320000] [<800c1ec8>] ag71xx_poll+0x3fc/0x5d0
[   53.320000] [<801e277c>] net_rx_action+0x10c/0x1e0
[   53.320000] [<80091330>] __do_softirq+0xf8/0x230
[   53.320000] [<80138e68>] do_softirq+0x48/0x68
[   53.320000] [<8009f9f8>] __local_bh_enable_ip+0x98/0xb8
[   53.320000] [<8011a90c>] del_nbp+0x8c/0x134
[   53.320000] [<800eb14c>] br_del_if+0x40/0xa0
[   53.320000] [<8011fb18>] dev_ifsioc+0x30c/0x330
[   53.320000] [<8012022c>] dev_ioctl+0x5d8/0x6c8
[   53.320000] [<8013c254>] do_vfs_ioctl+0x4d0/0x5dc
[   53.320000] [<8007470c>] SyS_ioctl+0x50/0x94
[   53.320000] [<80062b5c>] handle_sys+0x11c/0x140
[   53.320000] 
[   53.320000] 
Code: 8c430000  3063c000  2c630001 <00030336> 8c450000  7ca50380  10a00002  00000000  8c450038 
[   53.720000] ---[ end trace c90b8554e8dd286d ]---
[   53.730000] Kernel panic - not syncing: Fatal exception in interrupt
[   53.730000] Rebooting in 3 seconds..

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by nbd

You've been creating a large number of kernel oops tickets. I believe they may all be related and caused by some memory corruption issues triggered by something else not shown in the crash.

Unless you have strong reasons to believe that they are NOT related, please stop creating new tickets.

Please try to narrow down the cause by trying to individually disable things like ebtables, ipsec, batman-advanced to see if these errors stop triggering.

comment:2 Changed 3 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.