Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#19228 closed defect (moved_to_github)

Not able to build freeradius tool from openwrt trunk?

Reported by: uddandibharath7 Owned by: developers
Priority: highest Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

hi .,
I am using CHAOS CALMER (Gate works Ventana r710, r42297) image on gateworks 5200 board
Enabled freeradius tool from config with following modules
openwrt/trunk$make menuconfig

--->network

--->freeRADIUS(version 2)

and enabled following options
freeradius2 freeradius2-mod-always freeradius2-mod-attr-filter freeradius2-mod-attr-rewrite freeradius2-mod-chap freeradius2-mod-detail freeradius2-mod-eap freeradius2-mod-eap-gtc freeradius2-mod-eap-md5 freeradius2-mod-eap-mschapv2 freeradius2-mod-eap-peap freeradius2-mod-eap-tls freeradius2-mod-eap-ttls freeradius2-mod-exec freeradius2-mod-expiration freeradius2-mod-expr freeradius2-mod-files freeradius2-mod-ldap freeradius2-mod-logintime freeradius2-mod-mschap freeradius2-mod-pap
freeradius2-mod-passwd freeradius2-mod-preprocess freeradius2-mod-radutmp freeradius2-mod-realm freeradius2-mod-sql-mysql freeradius2-mod-sql-pgsql freeradius2-mod-sql-sqlite freeradius2-mod-sqlcounter freeradius2-utils freeradius2-democerts

Having issue while building with these modules
freeradius2-mod-attr-rewrite......................... ATTR rewrite module
freeradius2-mod-ldap......................................... LDAP module
freeradius2-mod-radutmp............................... Radius UTMP module

Build logs as follows

cp: cannot stat `/home/Gateworks/gateworks-openwrt/trunk/build_dir/target-arm_cortex-a9+neon_uClibc-

0.9.33.2_eabi/freeradius-server-2.2.5/ipkg-install/usr/lib/freeradius2/rlm_radutmp.so': No such file or directory

cp: cannot stat `/home/Gateworks/gateworks-openwrt/trunk/build_dir/target-arm_cortex-a9+neon_uClibc-

0.9.33.2_eabi/freeradius-server-2.2.5/ipkg-install/usr/lib/freeradius2/rlm_radutmp-*.so': No such file or directory

with out enabling those three modules it is building fine

and it is installing radius_server version 2.2.5

but it is giving ERRORS related to radutmp (which is not loaded)after loading the image

Error logs from openwrt image as follows
Fri Mar 20 05:55:29 2015 : Error: /etc/freeradius2/sites/default[450]: Failed to find "radutmp" in the "modules" section.
Fri Mar 20 05:55:29 2015 : Error: /etc/freeradius2/sites/default[449]: Errors parsing session section.
Fri Mar 20 05:55:29 2015 : Error: Failed to load virtual server <default>

To setup radius Radius server i followed the method explained in this video
https://www.youtube.com/watch?v=PvUqMFvTOn8

Does any body working on this freeradius server ,please tell me how to setup freeradius server on openwrt ?
Thanks
sorry for my poor English,if it is not understandable let me know ,i will try to improve

Attachments (0)

Change History (5)

comment:1 Changed 3 years ago by nbd

  • Resolution set to moved_to_github
  • Status changed from new to closed

please don't use the bug tracker for support questions, maybe ask in the forum instead.

freeradius is maintained here: https://github.com/openwrt/packages, if there is a real bug, please report it there.

comment:2 Changed 3 years ago by Nilfred

Not a bug:

#  Session database, used for checking Simultaneous-Use. Either the radutmp 
#  or rlm_sql module can handle this.
#  The rlm_sql module is *much* faster
#session {
#	radutmp

	#
	#  See "Simultaneous Use Checking Queries" in sql.conf
#	sql
#}

/etc/freeradius2/sites/default uses radutmp for accounting by default.
Comment out that section if you don't do accounting at all.

comment:3 Changed 3 years ago by Nilfred

Oh! Wait! If I set CONFIG_PACKAGE_freeradius2-mod-radutmp=y or CONFIG_PACKAGE_freeradius2-mod-radutmp=m It doesn't compiles. But buildbot does... Weird.

comment:4 Changed 3 years ago by Nilfred

Not a bug:

make package/freeradius2/clean

Before compile it again with different settings works for me.

comment:5 Changed 3 years ago by bharath

It solved for me

Thanks a lot for spending your valuable time for me @Nilfred and @nbd

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.