Modify

Opened 12 years ago

Closed 12 years ago

#192 closed defect (fixed)

quagga doesnt make /var/run/quagga

Reported by: kevin@… Owned by: mbm/wbx
Priority: normal Milestone:
Component: packages Version:
Keywords: Cc:

Description

Hello,

I have updated m OpenWRT today from rc2 to rc4. When i finished it i wanted to install quagga this went smooth without any problems. Then i created /etc/quagga/zebra.conf and /etc/quagga/bgpd.conf to let "zebra" and "bgpd" start but then i found out a little problem. I've got the error message "bind: No such file or directory" After stracing the zebra daemon i saw this:

unlink("/var/run/quagga/zserv.api") = -1 ENOENT (No such file or directory)
umask(077) = 027
socket(PF_FILE, SOCK_STREAM, 0) = 4
bind(4, {sa_family=AF_FILE, path="/var/run/quagga/zserv.api"}, 27) = -1 ENOENT (No such file or directory)

Then i was like *BLING* the quagga package didnt create /var/run/quagga . After creating the directory then the bgp and zebra daemons work fine. I hope one of you guys can solve this problem.

big thanks already!!

Kevin aka Rawplayer

Attachments (0)

Change History (1)

comment:1 Changed 12 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r2864, thanks for reporting !

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.