Modify

Opened 3 years ago

Closed 2 years ago

#19189 closed defect (fixed)

Ralink driver crash

Reported by: wittywang@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: kernel Version: Trunk
Keywords: ralink rt3592 driver crash Cc:

Description (last modified by rmilecki)

My device is Huawei HG55a version C (HG56BZRB VER.A), and it has a Ralink wifi device.

After adding an additional client wifi interface in LuCI, I see some error messages in dmesg as below.

[  342.328000] ------------[ cut here ]------------
[  342.336000] WARNING: CPU: 0 PID: 1811 at /store/buildbot/slave/slave/brcm63xx/build/build_dir/target-mips_mips32_uClibc-0.9.33.2/linux-brcm63xx_generic/compat-wireless-2015-03-09/drivers/net/wireless/rt2x00/rt2800lib.c:1095 rt2800_get_txwi_rxwi_size+0x1a0/0x26c [rt2800lib]()
[  342.360000] Modules linked in: rt2800pci rt2800mmio rt2800lib pppoe ppp_async iptable_nat b43 rt2x00pci rt2x00mmio rt2x00lib pppox ppp_generic nf_nat_ipv4 nf_conntrack_ipv6 nf_conntrack_ipv4 mac80211 ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_state xt_nat xt_multiport xt_mark xt_mac xt_limit xt_id xt_conntrack xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_CT slhc nf_nat_irc nf_nat_ftp nf_nat nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack_irc nf_conntrack_ftp nf_conntrack iptable_raw iptable_mangle iptable_filter ipt_REJECT ip_tables crc_itu_t crc_ccitt compat ohci_platform ohci_hcd ip6t_REJECT ip6table_raw ip6table_mangle ip6table_filter ip6_tables x_tables ehci_platform ehci_hcd usbcore nls_base usb_common ipv6 eeprom_93cx6 arc4 crypto_blkcipher gpio_button_hotplug
[  342.432000] CPU: 0 PID: 1811 Comm: luci Not tainted 3.14.34 #1
[  342.436000] Stack : 00000006 00000000 00000000 00000000 00000000 00000000 804dcb3e 00000032
[  342.436000] 	  82d07858 830f9f40 80312648 80363053 00000713 804d3e60 82d07858 830f9f40
[  342.436000] 	  00000008 0000001c 00000001 8028eb04 00000003 801eaa60 00000447 830f9f40
[  342.436000] 	  803155a0 82ea176c 00000000 00000000 00000000 00000000 00000000 00000000
[  342.436000] 	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[  342.436000] 	  ...
[  342.472000] Call Trace:
[  342.476000] [<802296f8>] show_stack+0x48/0x70
[  342.480000] [<802a11c0>] warn_slowpath_common+0x84/0xb4
[  342.488000] [<802a1278>] warn_slowpath_null+0x18/0x24
[  342.492000] [<8326436c>] rt2800_get_txwi_rxwi_size+0x1a0/0x26c [rt2800lib]
[  342.500000] 
[  342.500000] ---[ end trace 9c8c5399c6b94738 ]---
root@OpenWrt:~# lspci -nn
 00:01.0 Network controller [0280]: Ralink corp. RT3592 Wireless 802.11abgn 2T/2R PCIe [1814:3592]
 01:1e.0 CardBus bridge [0607]: Broadcom Corporation Device [14e4:6358]
root@OpenWrt:~# cat /etc/config/wireless
config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'pci0000:00/0000:00:01.0'
	option noscan '1'
	option htmode 'HT40'
	option country 'CN'
	option distance '50'
	option disabled '0'
	option txpower '10'
	option channel '6'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option ssid 'OpenWrt'
	option network 'lan'
	option encryption 'psk-mixed'
	option key '12345678'

config wifi-iface
	option network 'wwan'
	option ssid 'XXXXX'
	option encryption 'psk2'
	option device 'radio0'
	option mode 'sta'
	option bssid 'XX:XX:XX:XX:XX:XX'
	option key '********'
root@OpenWrt:~# iw dev
phy#0
	Interface wlan0-1
		ifindex 25
		wdev 0xd
		addr 00:0c:43:30:62:00
		type AP
	Interface wlan0
		ifindex 24
		wdev 0xc
		addr 00:0c:43:30:62:01
		type managed
root@OpenWrt:~# iw phy
Wiphy phy0
	max # scan SSIDs: 4
	max scan IEs length: 2257 bytes
	Retry short limit: 7
	Retry long limit: 4
	Coverage class: 0 (up to 0m)
	Available Antennas: TX 0 RX 0
	Supported interface modes:
		 * IBSS
		 * managed
		 * AP
		 * AP/VLAN
		 * WDS
		 * monitor
		 * mesh point
	Band 1:
		Capabilities: 0x2f2
			HT20/HT40
			Static SM Power Save
			RX Greenfield
			RX HT20 SGI
			RX HT40 SGI
			TX STBC
			RX STBC 2-streams
			Max AMSDU length: 3839 bytes
			No DSSS/CCK HT40
		Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
		Minimum RX AMPDU time spacing: 2 usec (0x04)
		HT RX MCS rate indexes supported: 0-15, 32
		TX unequal modulation not supported
		HT TX Max spatial streams: 2
		HT TX MCS rate indexes supported may differ
		Frequencies:
			* 2412 MHz [1] (20.0 dBm)
			* 2417 MHz [2] (20.0 dBm)
			* 2422 MHz [3] (20.0 dBm)
			* 2427 MHz [4] (20.0 dBm)
			* 2432 MHz [5] (20.0 dBm)
			* 2437 MHz [6] (20.0 dBm)
			* 2442 MHz [7] (20.0 dBm)
			* 2447 MHz [8] (20.0 dBm)
			* 2452 MHz [9] (20.0 dBm)
			* 2457 MHz [10] (20.0 dBm)
			* 2462 MHz [11] (20.0 dBm)
			* 2467 MHz [12] (20.0 dBm)
			* 2472 MHz [13] (20.0 dBm)
			* 2484 MHz [14] (disabled)
	valid interface combinations:
		 * #{ managed, AP, mesh point } <= 8,
		   total <= 8, #channels <= 1
	HT Capability overrides:
		 * MCS: ff ff ff ff ff ff ff ff ff ff
		 * maximum A-MSDU length
		 * supported channel width
		 * short GI for 40 MHz
		 * max A-MPDU length exponent
		 * min MPDU start spacing

Attachments (0)

Change History (5)

comment:1 Changed 3 years ago by rmilecki

  • Description modified (diff)

comment:2 Changed 2 years ago by evaxige@…

I have the same problem. My HW is WRTNode & VoCore, both of them use rt2800 driver. Use AP STA mode at same time, is will cause kernel crash. Google it, I found a mail list maybe fix it, Clickhttps://lists.openwrt.org/pipermail/openwrt-devel/2015-January/030906.html

comment:3 Changed 2 years ago by anonymous

had the same on my xiaomi mini and found the solution that was never committed: /ticket/20338.html

comment:4 Changed 2 years ago by evaxige@…

comment:5 Changed 2 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fix was committed in r47668

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.