Modify

Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#19174 closed defect (fixed)

ath10k and ieee80211w not working

Reported by: olmari Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: ath10k, ieee80211w Cc: nbd

Description

Using: r44750, Archer C7 v2

When I use "option ieee80211w 1" in wifi for ath10k radio, it does not come up:

Configuration file: /var/run/hostapd-phy0.conf
Using interface wlan0 with hwaddr xx:xx:xx:xx:xx:xx and ssid "something"
Interface initialization failed
wlan0: interface state UNINITIALIZED->DISABLED
wlan0: AP-DISABLED 
wlan0: Unable to setup interface.
hostapd_free_hapd_data: Interface wlan0 wasn't started
ELOOP: remaining socket: sock=19 eloop_data=0x9e45a8 user_data=(nil) handler=0x419925
radio0 (605): Device setup failed: HOSTAPD_START_FAILED

But when I remove the ieee80211w setting, the interface comes up normally. The 2.4GHz/ath9k radio works with setting enabled.

Attachments (0)

Change History (6)

comment:1 Changed 3 years ago by robstoon

I ran into this as well with r44879. Unfortunately whatever part in the hostapd setup is failing doesn't seem to see fit to output an error message.

I previously had ieee80211w enabled on the 2.4GHz/ath9k radio, but had to turn it off because some devices like Nexus 7 (2012) failed to connect with it enabled. Not sure if that was a device or AP-side issue.

comment:2 Changed 3 years ago by ignisf

Confirmed here, too. TP-LINK Archer c5 running r45621.

comment:3 Changed 3 years ago by ignisf

Netlink debug data if anybody can find a use for it:

Packet capture: https://storage.btroyan.info/petko/openwrt/netlink.pcapng
Debug info: https://storage.btroyan.info/petko/openwrt/netlink.txt

comment:4 Changed 3 years ago by olmari

okay, at least in trunk #46514 "option ieee80211w '1'" works as expected. I do have full wpad installed should that matter or not, but I think this ticket can be closed now

comment:5 Changed 2 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

comment:6 Changed 2 years ago by anonymous

@nbd, do you know which commit fixed it?

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.