Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#19126 closed defect (not_a_bug)

Adhoc Interface problem

Reported by: anonymous Owned by: developers
Priority: highest Milestone: Chaos Calmer 15.05
Component: kernel Version: Trunk
Keywords: Cc:

Description

Hi all

I'm sorry if I ask a stupid questions. I have a tiny router wt3020 with MT7620n chipset series from mediatek. When I configure for adhoc interface as same as my configuration in my tp-link mr3020, I get different result. The interface is not work as same as in my MR3020. It says "wireless maybe disable or Not Associated" . this my configuration :

/etc/config/wireless
config wifi-device 'radio0'

option type 'mac80211'
option channel '11'
option hwmode '11g'
option path '10180000.wmac'
option htmode 'HT20'
option txpower '20'
option country 'US'

config wifi-iface

option device 'radio0'
option encryption 'none'
option ssid 'OLSR'
option mode 'adhoc'
option network 'mywifi'

config wifi-iface

option device 'radio0'
option network 'lan'
option mode 'ap'
option encryption 'none'
option ssid 'WT3020'

/etc/config/network
config interface 'loopback'

option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'

option ula_prefix 'fdff:769b:2e48::/48'

config interface 'lan'

option ifname 'eth0.1'
option force_link '1'
option macaddr '20:28:18:a0:aa:06'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option ipaddr '192.168.20.1'
option dns '192.168.10.1 8.8.8.8'
option gateaway '192.168.10.6'

config interface 'wan'

option ifname 'eth0.2'
option force_link '1'
option macaddr '20:28:18:a0:aa:07'
option proto 'dhcp'

config interface 'wan6'

option ifname 'eth0.2'
option proto 'dhcpv6'

config switch

option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan

option device 'switch0'
option vlan '1'
option ports '1 2 3 4 6t'

config switch_vlan

option device 'switch0'
option vlan '2'
option ports '0 6t'

config interface 'mywifi'

option proto 'static'
option ipaddr '192.168.10.6'
option netmask '255.255.255.0'

there is a suggestions for me about my problem ? Thanks for read

Regards
Asriadi

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by nbd

  • Resolution set to not_a_bug
  • Status changed from new to closed

The wireless driver does not support running ad-hoc and AP mode at the same time.

comment:2 Changed 3 years ago by anonymous

Thanks for your comment, but after I disabled AP and just run adhoc mode, it's still not work. any advice ?

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.