Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#19113 closed defect (no_response)

kirkwood not booting 3.18 kernel

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: kernel Version: Trunk
Keywords: Cc:

Description

Building 3.18 kernel for Marvell Kirkwood results in non-booting zImage, hangs on

Starting kernel ...

and then nothing. Kernel 3.14 from downloads.openwrt.org trunk works fine.

U-Boot 2014.10

Attachments (1)

kirkwood.patch (7.8 KB) - added by anonymous 3 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 3 years ago by nbd

You forgot to mention what device you're trying to boot it on.

Changed 3 years ago by anonymous

comment:2 Changed 3 years ago by anonymous

Sorry, Pogoplug e02.

It's working now with custom kernel config I made quite a few changes. Unfortunately i don't know what caused the issue but I attach the patch in case someone is interested.

comment:3 Changed 3 years ago by KyleAnderson

Is it possible you were originally using the kirkwood-generic-* image and after you built a custom kernel you used a pogoplug specific one?

comment:4 Changed 3 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

comment:5 Changed 3 years ago by anonymous

Hi. I'm just a noob (I'm not the OP) but I experienced the same problem trying to get BB working on a Goflex Net. According to /ticket/14938.html it might be due to the absence of a DTB. I mention it in case this is related.
I'm still wanting to get Openwrt running on my device. Happy to do some testing if it helps.
Regards,
Dan.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.