Modify

Opened 3 years ago

Closed 3 years ago

#19065 closed defect (not_a_bug)

Opkg won't upgrade kmod again.Getting Multiple packages providing same name marked HOLD or PREFER. Using latest

Reported by: Halry Owned by: developers
Priority: high Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

Just using the newest build.It won't happen in bb.
Output:

root@OpenWrt:~# opkg update
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/nand/packages/base/Packages.gz.
Updated list of available packages in /var/opkg-lists/chaos_calmer_base.
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/nand/packages/telephony/Packages.gz.
Updated list of available packages in /var/opkg-lists/chaos_calmer_telephony.
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/nand/packages/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/chaos_calmer_packages.
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/nand/packages/routing/Packages.gz.
Updated list of available packages in /var/opkg-lists/chaos_calmer_routing.
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/nand/packages/luci/Packages.gz.
Updated list of available packages in /var/opkg-lists/chaos_calmer_luci.
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/nand/packages/management/Packages.gz.
Updated list of available packages in /var/opkg-lists/chaos_calmer_management.
root@OpenWrt:~# opkg list-upgradable
Multiple packages (kmod-usb-core and kmod-usb-core) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-nfnetlink and kmod-nfnetlink) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-lib-crc-ccitt and kmod-lib-crc-ccitt) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-ledtrig-usbdev and kmod-ledtrig-usbdev) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-nf-nathelper and kmod-nf-nathelper) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-pppoe and kmod-pppoe) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-pppox and kmod-pppox) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-ipt-conntrack and kmod-ipt-conntrack) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-nf-nat and kmod-nf-nat) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-usb-ohci and kmod-usb-ohci) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-usb2 and kmod-usb2) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-nf-ipt and kmod-nf-ipt) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-ip6tables and kmod-ip6tables) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-crypto-aes and kmod-crypto-aes) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-crypto-core and kmod-crypto-core) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-sched and kmod-sched) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-ipt-core and kmod-ipt-core) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-ipv6 and kmod-ipv6) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-ppp and kmod-ppp) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-nf-conntrack and kmod-nf-conntrack) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-nf-ipt6 and kmod-nf-ipt6) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-nf-conntrack6 and kmod-nf-conntrack6) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-nls-base and kmod-nls-base) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-crypto-arc4 and kmod-crypto-arc4) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-slhc and kmod-slhc) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-ipt-nat and kmod-ipt-nat) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-sched-core and kmod-sched-core) providing same name marked HOLD or PREFER. Using latest.

It seems some old problem get out
https://code.google.com/p/wl500g-repo/issues/detail?id=28

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by jow

  • Resolution set to not_a_bug
  • Status changed from new to closed

You cannot upgrade kmods with opkg.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.