Modify

Opened 3 years ago

Closed 3 years ago

#18957 closed defect (fixed)

build trunk fails with awk: calling undefined function asort

Reported by: unki@… Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

GIT commit 80710b0f2796c0573e78d200ec185e3d8d7db0c8 introduced an issue for me compiling latest trunk failing with an awk error message:

awk: calling undefined function asort

I'm building OpenWrt on OS X 10.10.2 where awk is provided in a version called 20070501.
I have also installed GNU awk from macports where awk is then available on my system in version 'GNU Awk 4.1.1' - but it's binary is called 'gawk'.

While include/prereq-build.mk takes care of this and will select 'gawk' rather than 'awk' on my system, include/scan.mk doesn't consider this and always calls 'awk'.

Attachments (0)

Change History (4)

comment:1 Changed 3 years ago by unki_at

BTW, of course as a hotfix replacing all 'awk' by 'gawk' in include/scan.mk works

comment:2 Changed 3 years ago by jow

Please try the following change without any other workarounds:

  • include/host.mk

    diff --git a/include/host.mk b/include/host.mk
    index 4ca8140..ab50879 100644
    a b  
    55# See /LICENSE for more information. 
    66# 
    77 
     8export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH) 
     9 
    810TMP_DIR ?= $(TOPDIR)/tmp 
    911ifeq ($(if $(TARGET_BUILD),,$(DUMP)),) 
    1012  -include $(TMP_DIR)/.host.mk 

comment:3 Changed 3 years ago by anonymous

I can confirm that your fix works for me and I'm not experiencing any further awk issue during a build on OS X.

Thx!

comment:4 Changed 3 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

Fix committed in r44378

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.