Modify

Opened 3 years ago

#18954 new defect

MTU of IPv6 link ignored after reboot

Reported by: ashus Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: other Version: Trunk
Keywords: ipv6, ppp, mtu, 6in4 Cc:

Description

I have a TP-Link 1043ND v1 set up to connect via ppp on wan with 6in4 HEnet tunnel. The problem is to make it work, i need to lower the MTU of IPv6 link. If I run the commands below, the MTU is applied correctly and the link becomes active. The problem is I have to run this after each router reboot:

uci set network.wan6.mtu=1451
uci commit network.wan6
/etc/init.d/network reload
# part 2
uci set network.wan6.mtu=1452
uci commit network.wan6
/etc/init.d/network reload

When running only the part 2 it still doesn't come up. I've been able to successfully recreate the bug in BB and in CC trunk (all tested builds).

Attachments (0)

Change History (0)

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.