Modify

Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#18931 closed defect (fixed)

Xiaomi miwifi mini, WIFI BUG

Reported by: vamadir Owned by: developers
Priority: highest Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: Cc:

Description

After install openwrt-ramips-mt7620-xiaomi-miwifi-mini rom. Not correct working wireless. Not very unstable signal and low signal. Aftre chaging some setting in /etc/config/wireless, 5G network not working.

this is /etc/config/wireless

config wifi-device 'radio0'

option type 'mac80211'
option channel '36'
option hwmode '11a'
option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
option htmode 'VHT80'
option disabled '0'

config wifi-iface

option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'none'

config wifi-device 'radio1'

option type 'mac80211'
option channel '11'
option hwmode '11g'
option path '10180000.wmac'
option htmode 'HT20'
option disabled '1'

config wifi-iface

option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'none'

installed: kmod-rt2800-pci kmod-rt2800-soc kmod-rt2800-pci kmod-rt2800-lib kmod-rt2800-mmio kmod-rt2x00-lib kmod-rt2x00-mmio kmod-rt2x00-pci kmod-mac80211 kmod-mt76

wifi 1: SoC-integrated: MT7620A 2x2 MIMO 802.11b/g/n
wifi 2: On-board chip: MT7612E 2x2 MIMO 802.11a/n/ac (5 GHz)

Attachments (0)

Change History (19)

comment:1 Changed 3 years ago by vamadir

i think problem with kmod-mt76

comment:2 Changed 3 years ago by dupidog@…

You can add device tree node in dts file, which can solve part of the problem.
Add pcie-bridge node as follows to the pcie@1014000 node.

pcie@10140000 {

status = "okay";

pcie-bridge {

mt76@0,0 {

reg = <0x0000 0 0 0 0>;
device_type = "pci";
mediatek,mtd-eeprom = <&factory 0x8000>;

};

};

};

comment:3 Changed 3 years ago by vamadir

ok, thanks. Its fixed /changeset/44355.html

comment:4 Changed 3 years ago by anonymous

Still unstable signal :(

comment:5 Changed 3 years ago by anonymous

I agree.. even 2.4 Ghz wifi is unstable..

comment:6 Changed 3 years ago by anonymous

5GHz with latest trunk working good. 2.4GHz, low signal power, but stable.

comment:7 Changed 3 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

comment:8 Changed 2 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

2.4GHz=weak signal, low throughput
5GHz=weak signal, normal throughput

reopening since problem not fixed

comment:9 Changed 2 years ago by anonymous

update:

latest trunk 5GHz is fixed but 2.4GHz still about 20dB lower signal than factory fw.

2.4GHz network is slow.

comment:11 Changed 2 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:12 follow-up: Changed 2 years ago by akhabrov@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

My iPhone 5 didn't see 5G network at all on last trunk!
2.4G working perfectly with power level as on original firmware.

comment:13 in reply to: ↑ 12 Changed 2 years ago by akhabrov

Replying to akhabrov@…:

My iPhone 5 didn't see 5G network at all on last trunk!
2.4G working perfectly with power level as on original firmware.

Sorry, my fault!
May be a reason in Luci bug?

Xiaomi miwifi not accepted all 5G channels and bandwidths to use.
For example 48 channel and 20Mhz bandwidth works fine.
On error you should reboot your router.

But tx power level never raised more than 17dBm...

comment:14 Changed 2 years ago by anonymous

only channels 36-48 seem to be working on 5GHz: /ticket/20335.html and /ticket/20343.html

comment:15 Changed 2 years ago by nbd

that's normal. there is no DFS support yet.

comment:16 Changed 2 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:17 Changed 2 years ago by anonymous

so how to remove DFS flags from these channels in regdb? tried the same as i do for 2.4G wifi but for 5G it didn't had any effect?

comment:18 Changed 2 years ago by anonymous

radio0 (5G) does not accept channel=0 config (to autodetect the best channel)

comment:19 Changed 2 years ago by anonymous

here is the log:

Wed Sep 30 17:33:41 2015 daemon.notice netifd: radio0 (7656): Configuration file: /var/run/hostapd-phy0.conf
Wed Sep 30 17:33:42 2015 daemon.notice netifd: radio0 (7656): ACS: Automatic channel selection started, this may take a bit
Wed Sep 30 17:33:42 2015 daemon.notice netifd: radio0 (7656): wlan0: interface state UNINITIALIZED->ACS
Wed Sep 30 17:33:42 2015 daemon.notice netifd: radio0 (7656): wlan0: ACS-STARTED 
Wed Sep 30 17:33:42 2015 daemon.notice netifd: radio0 (7656): handle_probe_req: send failed
Wed Sep 30 17:33:44 2015 daemon.notice netifd: radio0 (7656): ACS: Unable to collect survey data
Wed Sep 30 17:33:44 2015 daemon.notice netifd: radio0 (7656): ACS: All study options have failed
Wed Sep 30 17:33:44 2015 daemon.notice netifd: radio0 (7656): Interface initialization failed
Wed Sep 30 17:33:44 2015 daemon.notice netifd: radio0 (7656): wlan0: interface state ACS->DISABLED
Wed Sep 30 17:33:44 2015 daemon.notice netifd: radio0 (7656): wlan0: AP-DISABLED 
Wed Sep 30 17:33:44 2015 daemon.notice netifd: radio0 (7656): ACS: Possibly channel configuration is invalid, please report this along with your config file.
Wed Sep 30 17:33:44 2015 daemon.notice netifd: radio0 (7656): ACS: Failed to start
Wed Sep 30 17:33:44 2015 daemon.notice netifd: radio0 (7656): wlan0: AP-DISABLED 
Wed Sep 30 17:33:44 2015 daemon.notice netifd: radio0 (7656): hostapd_free_hapd_data: Interface wlan0 wasn't started
Wed Sep 30 17:33:44 2015 daemon.notice netifd: radio0 (7656): nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Wed Sep 30 17:33:44 2015 daemon.notice netifd: radio0 (7656): wlan0: interface state DISABLED->DISABLED
Wed Sep 30 17:33:44 2015 daemon.notice netifd: radio0 (7656): wlan0: interface state DISABLED->DISABLED
Wed Sep 30 17:33:44 2015 daemon.notice netifd: radio0 (7656): wlan0: AP-DISABLED 
Wed Sep 30 17:33:44 2015 daemon.notice netifd: radio0 (7656): hostapd_free_hapd_data: Interface wlan0 wasn't started
Wed Sep 30 17:33:55 2015 daemon.notice netifd: radio0 (7796): Configuration file: /var/run/hostapd-phy0.conf
Wed Sep 30 17:33:56 2015 daemon.notice netifd: radio0 (7796): ACS: Automatic channel selection started, this may take a bit
Wed Sep 30 17:33:56 2015 daemon.notice netifd: radio0 (7796): wlan0: interface state UNINITIALIZED->ACS
Wed Sep 30 17:33:56 2015 daemon.notice netifd: radio0 (7796): wlan0: ACS-STARTED 
Wed Sep 30 17:33:58 2015 daemon.notice netifd: radio0 (7796): ACS: Unable to collect survey data
Wed Sep 30 17:33:58 2015 daemon.notice netifd: radio0 (7796): ACS: All study options have failed
Wed Sep 30 17:33:58 2015 daemon.notice netifd: radio0 (7796): Interface initialization failed
Wed Sep 30 17:33:58 2015 daemon.notice netifd: radio0 (7796): wlan0: interface state ACS->DISABLED
Wed Sep 30 17:33:58 2015 daemon.notice netifd: radio0 (7796): wlan0: AP-DISABLED 
Wed Sep 30 17:33:58 2015 daemon.notice netifd: radio0 (7796): ACS: Possibly channel configuration is invalid, please report this along with your config file.
Wed Sep 30 17:33:58 2015 daemon.notice netifd: radio0 (7796): ACS: Failed to start
Wed Sep 30 17:33:58 2015 daemon.notice netifd: radio0 (7796): wlan0: AP-DISABLED 
Wed Sep 30 17:33:58 2015 daemon.notice netifd: radio0 (7796): hostapd_free_hapd_data: Interface wlan0 wasn't started
Wed Sep 30 17:33:58 2015 daemon.notice netifd: radio0 (7796): nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Wed Sep 30 17:33:58 2015 daemon.notice netifd: radio0 (7796): wlan0: interface state DISABLED->DISABLED
Wed Sep 30 17:33:58 2015 daemon.notice netifd: radio0 (7796): wlan0: interface state DISABLED->DISABLED
Wed Sep 30 17:33:58 2015 daemon.notice netifd: radio0 (7796): wlan0: AP-DISABLED 
Wed Sep 30 17:33:58 2015 daemon.notice netifd: radio0 (7796): hostapd_free_hapd_data: Interface wlan0 wasn't started

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.