Modify

Opened 3 years ago

Closed 3 years ago

#18884 closed defect (not_a_bug)

sysupgrade ignores return codes of called binaries

Reported by: yanosz Owned by: developers
Priority: normal Milestone:
Component: base system Version: Barrier Breaker 14.07
Keywords: Cc:

Description

We noticed that sysupgrades ignores errors such as:

  • tar is not supporting gzip
  • find is missing

In these situations, no error is reported - sysupgrade goes on as usual, preventing configuration from been taken over.
IMO sysupgrade should honor return codes of called binaries (find, tar, etc.). If an error occurs, the user should be asked to perform a backup on its own.

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by jow

  • Resolution set to not_a_bug
  • Status changed from new to closed

Since this is a problem occurring with non-default configurations it is a feature request and not a bug. Feel free to send a patch according to SubmittingPatches.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.