Modify

Opened 3 years ago

Last modified 3 years ago

#18845 new defect

Mikrotik RB2011UiAS-IN - GE ports problem

Reported by: pavera@… Owned by: developers
Priority: highest Milestone:
Component: kernel Version: Trunk
Keywords: Cc:

Description

Kernel recognizes the port status but communication is not possible. RB2011UiAS-IN has probably different SoC - AR9344 rev. 3. I have no problem with an older revision (rev. 2)

Attachments (0)

Change History (5)

comment:1 Changed 3 years ago by anonymous

Althrough the same problem was solved for rb2011 models with Wifi, exactly as new rb951g versions mentioned here /ticket/18433.html
My rb2011UiAS-RM still do not pass traffic of eth0. There must be something different in models without Wifi. I suspect there is something wrong with MAC addresses, but that is just guess.

comment:2 Changed 3 years ago by anonymous

Well after a lot of attempts to build trunk and after that also barrier (i guess a lot of them was just a wasted time for void, because kernel was not recompiled by simly run "make"?),

my rb2011UiAS-RM start working.. with pll_1000 = 0x6f000000. But my rb951 works with 0x3e000000, with which rb2011 does not work well enough to provide DHCP to client (almost all packets lost).

If I can say an opinion, problem would be solved by detecting the right pll_1000 value somehow, as it seems like it is not equal for all devices?
Anyway, I post again here because my guess was wrong (as well as topic says), and there was nothing else breaking the data, just the pll_1000 value.
Note that patch is not in main repo, so You must try.

comment:3 Changed 3 years ago by anonymous

Thanks. I will try.

comment:4 Changed 3 years ago by jn.coueron

The problem is linked to the bootloader.
If you downgrade the bootloader to 3.10 the GE ports works.

You can downgrade it from serial port
restart and press key to stop bootloader
press g - upgrade firmware
press s - upgrade firmware over serial port

you can download the bootloader ready to be send by serial port (Xmodem)
http://i.mt.lv/routerboard/files/ar9344_3.10.fwf

the downgrade was tested on RB2011UiAS-RM and RB2011UiAS-IN.

comment:5 Changed 3 years ago by jn.coueron@…

From the version 3.22 version of the bootloader downgrade is impossible (new feature from mikrotik)
The boot loader version is send to kernel by kernel command line :
[ 0.000000] Kernel command line: console=ttyS0,115200 lcd_ctrl=92 parts=1 boot_part_size=4194304 gpio=249387 HZ=300000000 mem=128M kmac=4C:5E:0C:XX:XX:XX board=2011r5 ver=3.22 hw_opt=00718004 boot=1 mlc=8 rootfstype=yaffs noinitrd

if someone can patch mach-rb95x.c to have the right value of ath79_eth0_pll_data.pll_1000 in function of the hw_opt flag

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.