Modify

Opened 3 years ago

Closed 3 years ago

#18841 closed defect (fixed)

MT76X2 wifi chip problem

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: mt76 Cc:

Description

the MT76x2 driver maybe have problem .(trunk/package/kernel/mt76)
my board is using MT7602 + MT7612 .

but ,the driver generate /etc/config/wireless like this :

config wifi-device radio0

option type mac80211
option channel 36
option hwmode 11a
option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
option htmode VHT80
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 1

config wifi-iface

option device radio0
option network lan
option mode ap
option ssid OpenWrt
option encryption none

config wifi-device radio1

option type mac80211
option channel 36
option hwmode 11a
option path 'pci0000:00/0000:00:01.0/0000:02:00.0'
option htmode VHT80
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 1

config wifi-iface

option device radio1
option network lan
option mode ap
option ssid OpenWrt
option encryption none

YOU can see , the driver cannot identity 5G and 2.4G wifi chip.

i check the source code and found this line in "mac80211.sh"
vht_cap=$(iw phy "$dev" info | grep -c 'VHT Capabilities')
[ "$vht_cap" -gt 0 ] && {

mode_band="a";
channel="36"
htmode="VHT80"

}

so , i try to exec in command line (phy1 is mt7602):

root@OpenWrt:/# iw phy phy1 info
Wiphy phy1

max # scan SSIDs: 4
max scan IEs length: 2243 bytes
Retry short limit: 7
Retry long limit: 4
Coverage class: 0 (up to 0m)
Available Antennas: TX 0 RX 0
Supported interface modes:

  • IBSS
  • managed
  • AP
  • AP/VLAN
  • monitor

Band 1:

Capabilities: 0x1f3

RX LDPC
HT20/HT40
Static SM Power Save
RX Greenfield
RX HT20 SGI
RX HT40 SGI
TX STBC
RX STBC 1-stream
Max AMSDU length: 3839 bytes
No DSSS/CCK HT40

Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
Minimum RX AMPDU time spacing: 4 usec (0x05)
HT TX/RX MCS rate indexes supported: 0-15
VHT Capabilities (0x000001b0):

Max MPDU length: 3895
Supported Channel Width: neither 160 nor 80+80
RX LDPC
short GI (80 MHz)
TX STBC

VHT RX MCS set:

1 streams: MCS 0-9
2 streams: MCS 0-9
3 streams: not supported
4 streams: not supported
5 streams: not supported
6 streams: not supported
7 streams: not supported
8 streams: not supported

VHT RX highest supported: 0 Mbps
VHT TX MCS set:

1 streams: MCS 0-9
2 streams: MCS 0-9
3 streams: not supported
4 streams: not supported
5 streams: not supported
6 streams: not supported
7 streams: not supported
8 streams: not supported

VHT TX highest supported: 0 Mbps
Frequencies:

  • 2412 MHz [1] (20.0 dBm)
  • 2417 MHz [2] (20.0 dBm)
  • 2422 MHz [3] (20.0 dBm)
  • 2427 MHz [4] (20.0 dBm)
  • 2432 MHz [5] (20.0 dBm)
  • 2437 MHz [6] (20.0 dBm)
  • 2442 MHz [7] (20.0 dBm)
  • 2447 MHz [8] (20.0 dBm)
  • 2452 MHz [9] (20.0 dBm)
  • 2457 MHz [10] (20.0 dBm)
  • 2462 MHz [11] (20.0 dBm)
  • 2467 MHz [12] (20.0 dBm) (no IR)
  • 2472 MHz [13] (20.0 dBm) (no IR)
  • 2484 MHz [14] (20.0 dBm) (no IR)

valid interface combinations:

  • #{ IBSS } <= 1, #{ managed, AP } <= 8, total <= 8, #channels <= 1, STA/AP BI must match

HT Capability overrides:

  • MCS: ff ff ff ff ff ff ff ff ff ff
  • maximum A-MSDU length
  • supported channel width
  • short GI for 40 MHz
  • max A-MPDU length exponent
  • min MPDU start spacing

PYH1 is MT7602, should not have VHT Capabilities.

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in the current version of mt76

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.