Modify

Opened 11 years ago

Closed 11 years ago

Last modified 4 years ago

#1878 closed defect (fixed)

iptraf does not compile

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: Cc:

Description

same error again as described in ticket #1008. seems the patch isn't enough anymore.

also see the new buildlog...

Attachments (2)

buildlog.txt (9.6 KB) - added by anonymous 11 years ago.
fix-toolchain.patch (440 bytes) - added by anonymous 11 years ago.

Download all attachments as: .zip

Change History (9)

Changed 11 years ago by anonymous

comment:1 Changed 11 years ago by jirif <jiri.fojtasek@…>

The problem is broken toolchain, since quilt changes.

Simple copy/paste patch:

in file toolchain/kernel-headers/Makefile:

else
+Kernel/Patch:=$(Kernel/Patch/Default)
define Build/Prepare

comment:2 Changed 11 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Seems to be fixed by now, I cannot reproduce the bug.

comment:3 Changed 11 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

it does not work here. so, not fixed.

comment:4 Changed 11 years ago by jirif <jiri.fojtasek@…>

florian@lol Try recompile the toolchain ;) then apply my fix and recompile the toolchain again. The problem is that generic patches from 2.6 are not prepared in to kernel headers, so fix #1008 is not applied.

Changed 11 years ago by anonymous

comment:5 Changed 11 years ago by anonymous

confirmed. after applying your patch recompiling the toolchain with 'make toolchain/{clean,install}' iptraf is happy and compiles fine.

i don't know if this is the correct way of fixing this problem. i think nbd knows what to fix...

comment:6 Changed 11 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

fixed in [7586]

comment:7 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.