Modify

Opened 3 years ago

Closed 2 years ago

#18712 closed defect (fixed)

A5-V11 images missing in ramips-rt305x snapshots

Reported by: probono Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

openwrt-ramips-rt305x-a5-v11-squashfs-factory.bin and openwrt-ramips-rt305x-a5-v11-squashfs-sysupgrade.bin are missing on https://downloads.openwrt.org/snapshots/trunk/ramips/

Please add the A5-V11 to the snapshots.

There is a CONFIG_TARGET_ramips_rt305x_A5-V11 target and the Image Generator can build these with:

make image PROFILE=A5-V11

I can confirm that the A5-V11 produced by the Image Generator works on the A5-V11 device.

Attachments (0)

Change History (24)

comment:1 Changed 3 years ago by rod@…

I am also interested in this image becoming part of the truck images.

comment:2 Changed 3 years ago by rod@…

I am also interested in this image becoming part of the truck images.

comment:3 Changed 3 years ago by anonymous

Someone who knows, please inform us how we can get this into the trunk images.

comment:4 Changed 3 years ago by anonymous

+1

Please can this be added.

comment:5 Changed 3 years ago by edswanston(At)hotmail.com

+1 more

have limited band width to get 1.7g development package.
thanks.

comment:6 Changed 3 years ago by anonymous

Really hope this great and cheap device can be added to the snapshots. Thank you

comment:7 Changed 3 years ago by anonymous

+1 also from my side.

However, as http://wiki.openwrt.org/toh/unbranded/a5-v11#known_issues mentions (and as I can confirm), the current ImageBuilder (as of 02/25/2015) can not be used to generate an image that holds the configuration settings.

comment:8 Changed 3 years ago by Whiterat

too many packages (or openwrt has got too fat)

A small amount of storage is required for the jffs2 partition (used in conjunction with overlayfs)

As to the exact amount required.. jffs2 needs 5 erase blocks minimum and a standard mtd erase block is 128kb, So 640kb free.

There is no check for this in the openwrt build process as far as I’m aware?

comment:9 Changed 3 years ago by maurer

so it will work if we remove some packages from a5-v11 profile ?

comment:10 Changed 3 years ago by anonymous

Sure.
I build without the below:
-dnsmasq
-firewall
-ip6tables
-iptables
-opkg
-ppp
-ppp-mod-pppoe

Which results in plenty of room.

root@OpenWrt:/# df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                    1.1M    224.0K    928.0K  19% /
/dev/root                 1.5M      1.5M         0 100% /rom
tmpfs                    14.2M     36.0K     14.1M   0% /tmp
/dev/mtdblock6            1.1M    224.0K    928.0K  19% /overlay
overlayfs:/overlay        1.1M    224.0K    928.0K  19% /
tmpfs                   512.0K         0    512.0K   0% /dev

There is only 4mb to play with and you've got uboot, uboot config and the kernel in there too. (~1.25mb)
Strip what you don't need; use busybox applets instead of full blown gnu utils where feasible.
Also bear in mind that kernel modules take up more room when not part of the kernel itself so if there are modules you need then build them in and save a little room.
(Although of course the last 2 are not something you can do with imagebuilder).

comment:11 Changed 3 years ago by anonymous

Please include this in the nightly builds

comment:12 Changed 3 years ago by anonymous

Please include this in the snapshots

comment:13 Changed 3 years ago by anonymous

Please include this in the snapshots

comment:14 Changed 3 years ago by anonymous

The storage issue can be resolved using extroot I guess? there is a USB port present. So more storage can be added that way.

comment:15 Changed 3 years ago by anonymous

Please include in nightly builds

comment:16 Changed 3 years ago by Morten

I belive I have this router (picture is the same except mine is black, PCB has the printing A5-V11 and it is 4MB/32MB).

I just installed the Hame MPR-A1 firmware after upgrading the uboot, following this guide: http://my-embedded.blogspot.dk/2014/01/mini-usb-portable-3g4g-router-rt5350f.html

I first installed the initram version, since I think I read somewhere you needed to do that. Then the normal squashfs.

Everything seems to be working (including Luci), only problem so far is if I set it up as a wifi-repeater, it is unreacable if booted without contact to the internet AP.

comment:17 Changed 3 years ago by maurer

use this script http://vonger.cn/?p=1778 to fix connectivity without internet AP

comment:18 Changed 3 years ago by Morten

Nice one maurer!

I will try that. Also nice with a good explanation to why it is like that. Now it all makes sense to me :)

comment:19 Changed 2 years ago by dev.openwrt.org@…

subcribe myself for updates to this ticket, hoping it will be fixed soon.

comment:20 Changed 2 years ago by lazna

Please include in nightly builds

comment:21 Changed 2 years ago by anonymous

So? :-)

comment:22 Changed 2 years ago by anonymous

So? :-)

comment:23 Changed 2 years ago by parrotgeek1@…

There is a typo in the script that builds the kernel for all rt3050 at once
target/linux/ramips/rt3050/kernel/image/Makefile

$(call Image/Build/Profile/A5-11,$(1))

is missing a V
it should be

$(call Image/Build/Profile/A5-V11,$(1))

comment:24 Changed 2 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r47627

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.