Modify

Opened 3 years ago

Closed 3 years ago

#18644 closed defect (fixed)

rtorrent keeps crashing (unhandled std::exception)

Reported by: tp3t3r@… Owned by: developers
Priority: normal Milestone:
Component: packages Version: Barrier Breaker 14.07
Keywords: rtorrent std::exception crash Cc: tp3t3r@…

Description

Hi,
I've noticed that Rtorrent keeps crashing every time while checking hash on completed torrent.

root@router:~# rtorrent -n -o import=/opt/etc/rtorrent.conf
(... it runs for a few minutes, then: )
rtorrent: std::exception
root@router:~# opkg info rtorrent
opkg inPackage: rtorrent
Version: 0.9.4-git--1
Depends: libc, libcurl, libtorrent, libncursesw, libsigcxx, libpthread
Status: install user installed
fSection: net
Architecture: ar71xx
Maintainer: Peter Wagner <tripolar@gmx.at>
MD5Sum: 8ffd2143c9db0570bad488574bc9f604
Size: 245808
Filename: rtorrent_0.9.4-git--1_ar71xx.ipk
Source: feeds/packages/net/rtorrent
Description: rTorrent is a BitTorrent client for ncurses, using the libtorrent library.
 The client and library is written in C++ with emphasis on speed and
 efficiency, while delivering equivalent features to those found in GUI based
 clients in an ncurses client.
 This package is built without xmlrpc support
Installed-Time: 1419357045
root@router:~# opkg info libtorrent
Package: libtorrent
Version: 0.13.4-git-51cd5ea8913a5f5062813d9f5b6256c76d41ea11-1
Depends: libc, libopenssl, libsigcxx
Status: install ok installed
Section: libs
Architecture: ar71xx
Maintainer: Peter Wagner <tripolar@gmx.at>
MD5Sum: 927125dbd3823a19f6798313c441714a
Size: 301058
Filename: libtorrent_0.13.4-git-51cd5ea8913a5f5062813d9f5b6256c76d41ea11-1_ar71xx.ipk
Source: feeds/packages/libs/libtorrent
Description: LibTorrent is a BitTorrent library written in C++ for *nix, with a focus on
 high performance and good code. The library differentiates itself from other
 implementations by transfering directly from file pages to the network stack.
 On high-bandwidth connections it is able to seed at 3 times the speed of the
 official client.
Installed-Time: 1419357039
root@router:~# cat /etc/openwrt_release
DISTRIB_ID="OpenWrt"
DISTRIB_RELEASE="14.07"
DISTRIB_REVISION="r42625"
DISTRIB_CODENAME="barrier_breaker"
DISTRIB_TARGET="ar71xx/generic"
DISTRIB_DESCRIPTION="OpenWrt Barrier Breaker 14.07"
DISTRIB_TAINTS=""
root@router:~# cat /etc/openwrt_version
14.07

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by adaml

Similar issue here. Also ar71xx-based router (Netgear WNDR3700v2), the same distro & revision and the same package versions.

Haven't managed to complete a single torrent. First it crashes during the download and then on resume attempts it always crashes during hash checking.

Using a vfat USB stick ATM (tested with badblocks - all good), but will test with an HDD soon.

comment:2 Changed 3 years ago by adaml

Seems the issue is resolved in the latest github snapshots of rtorrent/libtorrent. Built the packages on my own and it's been working fine for a couple of days now.

comment:3 Changed 3 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.