Modify

Opened 3 years ago

Closed 3 years ago

#18643 closed defect (fixed)

LuCI interface for new wifi 5g on TP-LINK C7 ends with error

Reported by: martin@… Owned by:
Priority: normal Milestone: Chaos Calmer 15.05
Component: luci Version: Trunk
Keywords: Cc:

Description

Operating frequency popup fields are not populated, will be attached

the error message is
/usr/lib/lua/luci/dispatcher.lua:448: Failed to execute arcombine dispatcher target for entry '/admin/network/wireless/radio0.network1'.
The called action terminated with an exception:
/usr/lib/lua/luci/model/cbi/admin_network/wifi.lua:187: attempt to index field 'hwmodelist' (a nil value)
stack traceback:

[C]: in function 'assert'
/usr/lib/lua/luci/dispatcher.lua:448: in function 'dispatch'
/usr/lib/lua/luci/dispatcher.lua:195: in function </usr/lib/lua/luci/dispatcher.lua:194>

Attachments (1)

snímek1.png (14.6 KB) - added by martin@… 3 years ago.
screenshot of unpopulated 'Operating frequency' popup menus

Download all attachments as: .zip

Change History (5)

Changed 3 years ago by martin@…

screenshot of unpopulated 'Operating frequency' popup menus

comment:1 in reply to: ↑ description ; follow-up: Changed 3 years ago by anonymous

I have the same issue. Is there a manual work-a-round?
Replying to martin@…:

Operating frequency popup fields are not populated, will be attached

the error message is
/usr/lib/lua/luci/dispatcher.lua:448: Failed to execute arcombine dispatcher target for entry '/admin/network/wireless/radio0.network1'.
The called action terminated with an exception:
/usr/lib/lua/luci/model/cbi/admin_network/wifi.lua:187: attempt to index field 'hwmodelist' (a nil value)
stack traceback:

[C]: in function 'assert'
/usr/lib/lua/luci/dispatcher.lua:448: in function 'dispatch'
/usr/lib/lua/luci/dispatcher.lua:195: in function </usr/lib/lua/luci/dispatcher.lua:194>

comment:2 in reply to: ↑ 1 Changed 3 years ago by anonymous

OK I found myself ticket 16589:
https://dev.openwrt.org/ticket/16589#comment:88
"You must install additional package: kmod-ath10k after the initial install of the openwrt trunk image."

As the kernel driver is not installed the interface is not visible and luci is displaying a mess. After installing the kernel package and reboot everything works fine.

Replying to anonymous:

I have the same issue. Is there a manual work-a-round?
Replying to martin@…:

Operating frequency popup fields are not populated, will be attached

the error message is
/usr/lib/lua/luci/dispatcher.lua:448: Failed to execute arcombine dispatcher target for entry '/admin/network/wireless/radio0.network1'.
The called action terminated with an exception:
/usr/lib/lua/luci/model/cbi/admin_network/wifi.lua:187: attempt to index field 'hwmodelist' (a nil value)
stack traceback:

[C]: in function 'assert'
/usr/lib/lua/luci/dispatcher.lua:448: in function 'dispatch'
/usr/lib/lua/luci/dispatcher.lua:195: in function </usr/lib/lua/luci/dispatcher.lua:194>

comment:3 Changed 3 years ago by anonymous

this is resolved but i lost my password and username, so close it yourselves.

comment:4 Changed 3 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.