Modify

Opened 3 years ago

Last modified 21 months ago

#18627 reopened enhancement

[PATCH] No way to set supported data rates

Reported by: wilco@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Hi,

I have found no way to set the supported data rates in the config. I can set a basic rate, but that does not disable 802.11b rates, for instance.

I want to be able to set the data rates, like the minimum data rate should be 12Mbps (Best Current Practise for any WiFi setup, except VoWLAN, that still needs 6Mbps).

In hostapd.conf this is the supported_rates config option.

-- Wilco

Attachments (1)

supported-rates.patch (1.9 KB) - added by Wilco Baan Hofman <wilco@…> 3 years ago.
Patch to configure supported data rates for a radio interface

Download all attachments as: .zip

Change History (7)

Changed 3 years ago by Wilco Baan Hofman <wilco@…>

Patch to configure supported data rates for a radio interface

comment:1 Changed 3 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r43782, thanks.

comment:2 Changed 3 years ago by AndreiM

Thanks for this functionality. For some reason, it only works if I set both supported_rates and basic_rate under wifi-device. If I don't, netifd fails with “No rates remaining in supported/basic rate sets” and “Failed to prepare rates table”. By the way, based on the hostapd_add_rate() in the patch, here's my configuration:

list supported_rates '12000 18000 24000 36000 48000 54000'
list basic_rate '12000 24000 54000'

comment:3 Changed 3 years ago by nbd

makes sense that it would fail, if the basic rate defaulted to something that you're no longer having in supported rates.

comment:4 Changed 21 months ago by valentt

I have tried:
list supported_rates '12000 18000 24000 36000 48000 54000'
list basic_rate '12000 24000 54000'

And on TPLINK WDR4300 running CC 15.04.01
on 2.4Ggz interface: Bit Rates:12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
but 5.8 Ghz interface: Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s

Any ideas why it works for 2.4Ghz but not for 5.8Ghz interface?

comment:5 Changed 21 months ago by valentt

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:6 Changed 21 months ago by valentt

It looks like supported_rates and basic_rates is added to /var/run/hostapd-phy0.conf but it is missing from /var/run/hostapd-phy1.conf

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.