Modify

Opened 3 years ago

Last modified 3 years ago

#18603 new defect

multicast do not work with multiple ip on wan

Reported by: twerrt Owned by: developers
Priority: normal Milestone:
Component: kernel Version: Barrier Breaker 14.07
Keywords: Cc:

Description

if you have working IPTV box try add second ip on your WAN interface (you do not even need default gw for that ip)

multicast traffic will stop forwarding trougth eth0 (wan) interface even if you add

rotue add -net 224.0.0.0/4 dev eth0 gw [your default gw]

config interface 'wan'

option ifname 'eth0'
option proto 'static'
option ipaddr '1.1.2.1'
option netmask '255.255.255.224'
option gateway '1.1.2.1'
option macaddr '1c:b:d:9:0:f'
option dns '8.8.8.8 8.8.4.4 2001:4860:4860::8888 2001:4860:4860::8844'
option metric 10


config interface 'local'

option ifname 'eth0'
option proto 'static'
option ipaddr '10.1.7.6'
option gateway '10.1.7.2'
option netmask '255.255.255.0'
option metric 15

Attachments (0)

Change History (4)

comment:1 Changed 3 years ago by twerrt

another bug: ifconfig unable to show multiple ipv4 on a interface

comment:2 Changed 3 years ago by cyrus

Whats the output of ip addr list? (after installing "ip")

Last edited 3 years ago by cyrus (previous) (diff)

comment:3 Changed 3 years ago by twerrt

it shows only one ip. like nothing changed 1 or 2 ip does not matter.

comment:4 Changed 3 years ago by twerrt

A little bit more words.

I test my IPTV with 2 configurations, with 1 and 2 ips. I did it for about 1 hour.

If I remove and keep only 1 ip (does not matter which) in my /etc/config/network I can see forwarding of 224./4 packets from br-lan interface to eth0.

If here is a 2 ips, no forwarding no matter what.

I used 'tcpdump -i br-lan igmp' and 'tcpdump -i eth0 igmp) to see packet forwarding.

With 2 ips, even 'route add -net 224.0.0.0/4 gw my_first_ip_gw dev eth0' or 'route add -net 224.0.0.0/4 gw my_second_ip_gw dev eth0'

Booth does not work.

I also tried to remove firewall rules and cleat it all /etc/init.d/firewall stop or iptables -F. No change.

It seems like a bug.

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.