Modify

Opened 3 years ago

Last modified 3 years ago

#18463 new defect

Compex wle600v5-23 (QCA9880) STA not connecting in 802.11ac mode

Reported by: mario_lopes Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

Hi there.

I'm using r43489 on cns3xxx, at AP and STA, and STA doesn't connect to AP. The STA detects AP by scanning.

Wireless security is set to "No Encryption". On menuconfig, "Firmware optimized for STA operation" is selected.

Also, relevant part of syslog of STA:

Tue Dec  2 12:18:45 2014 daemon.notice netifd: radio0 (899): Successfully initialized wpa_supplicant
Tue Dec  2 12:18:45 2014 daemon.notice netifd: radio0 (899): P2P: Failed to select random social channel as listen channel
Tue Dec  2 12:18:45 2014 daemon.notice netifd: radio0 (899): wlan0: Failed to init P2P
Tue Dec  2 12:18:46 2014 daemon.notice netifd: radio0 (899): cat: can't open '/var/run/wpa_supplicant-wlan0.pid': No such file or directory
Tue Dec  2 12:18:46 2014 daemon.notice netifd: radio0 (899): Command failed: Invalid argument
Tue Dec  2 12:18:46 2014 daemon.notice netifd: radio0 (899): Interface 0 setup failed: WPA_SUPPLICANT_FAILED
Tue Dec  2 12:18:46 2014 kern.info kernel: [   23.310000] eth0: link up, speed 1000 Mb/s, full duplex
Tue Dec  2 12:18:47 2014 daemon.notice netifd: Network device 'eth0' link is up
Tue Dec  2 12:18:47 2014 daemon.notice netifd: Interface 'lan' has link connectivity 
Tue Dec  2 12:19:03 2014 kern.notice kernel: [   39.680000] random: nonblocking pool is initialized
Tue Dec  2 12:25:03 2014 kern.info kernel: [  399.540000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Tue Dec  2 12:25:03 2014 daemon.notice netifd: radio0 (1826): Successfully initialized wpa_supplicant
Tue Dec  2 12:25:03 2014 daemon.notice netifd: radio0 (1826): P2P: Failed to select random social channel as listen channel
Tue Dec  2 12:25:03 2014 daemon.notice netifd: radio0 (1826): wlan0: Failed to init P2P
Tue Dec  2 12:25:03 2014 daemon.notice netifd: radio0 (1826): cat: can't open '/var/run/wpa_supplicant-wlan0.pid': No such file or directory
Tue Dec  2 12:25:03 2014 daemon.notice netifd: radio0 (1826): Command failed: Invalid argument
Tue Dec  2 12:25:03 2014 daemon.notice netifd: radio0 (1826): Interface 0 setup failed: WPA_SUPPLICANT_FAILED
Tue Dec  2 12:26:56 2014 authpriv.info dropbear[2032]: Child connection from 192.168.1.2:42514
Tue Dec  2 12:27:00 2014 authpriv.notice dropbear[2032]: Password auth succeeded for 'root' from 192.168.1.2:42514
Tue Dec  2 12:27:53 2014 kern.info kernel: [  569.560000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Tue Dec  2 12:27:53 2014 daemon.notice netifd: radio0 (2214): Successfully initialized wpa_supplicant
Tue Dec  2 12:27:53 2014 daemon.notice netifd: radio0 (2214): P2P: Failed to select random social channel as listen channel
Tue Dec  2 12:27:53 2014 daemon.notice netifd: radio0 (2214): wlan0: Failed to init P2P
Tue Dec  2 12:27:53 2014 daemon.notice netifd: radio0 (2214): cat: can't open '/var/run/wpa_supplicant-wlan0.pid': No such file or directory
Tue Dec  2 12:27:53 2014 daemon.notice netifd: radio0 (2214): Command failed: Invalid argument
Tue Dec  2 12:27:53 2014 daemon.notice netifd: radio0 (2214): Interface 0 setup failed: WPA_SUPPLICANT_FAILED

The syslog of AP don't show errors.

Thanks.

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by nbd

Have you tried disabling the "Firmware optimized for STA operation" option?

comment:2 Changed 3 years ago by mario_lopes

Yes, now it is working.

By the way, another issue, I am not receiving some e-mails about changelog or user comment input, like yours.

Thanks.

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.