Modify

Opened 3 years ago

Closed 3 years ago

#18458 closed defect (fixed)

kernel crash on openwrt-ar71xx-nand-wndr4300

Reported by: jianjia Owned by: developers
Priority: highest Milestone: Chaos Calmer 15.05
Component: kernel Version: Trunk
Keywords: Cc:

Description

svn revision is 43417

1>[71505.360000] CPU 0 Unable to handle kernel paging request at virtual address 00000000, epc == 86fe7770, ra == 86fe7778
<4>[71505.370000] Oops#1:
<4>[71505.370000] CPU: 0 PID: 1438 Comm: hostapd Not tainted 3.14.18 #71
<4>[71505.370000] task: 86b992c0 ti: 86a80000 task.ti: 86a80000
<4>[71505.370000] $ 0 : 00000000 00c14200 00000010 000f0000
<4>[71505.370000] $ 4 : 86e556c0 00000300 85f0143c 85f013ac
<4>[71505.370000] $ 8 : 00000a95 00000000 0000c4f0 00000001
<4>[71505.370000] $12 : ffffff80 86937919 000000a1 00000003
<4>[71505.370000] $16 : 85f0178c 00000000 0000000b 85f013ac
<4>[71505.370000] $20 : 86e556c0 00100000 86fe77f0 86fe7784
<4>[71505.370000] $24 : 00000000 86fe2870
<4>[71505.370000] $28 : 86a80000 86a816b8 86937918 86fe7778
<4>[71505.370000] Hi : 00000000
<4>[71505.370000] Lo : 0437b5c2
<4>[71505.370000] epc : 86fe7770 ath_tx_aggr_sleep+0x58/0x134 [ath9k]
<4>[71505.370000] Not tainted
<4>[71505.370000] ra : 86fe7778 ath_tx_aggr_sleep+0x60/0x134 [ath9k]
<4>[71505.370000] Status: 1100dc03 KERNEL EXL IE
<4>[71505.370000] Cause : 80800008
<4>[71505.370000] BadVA : 00000000
<4>[71505.370000] PrId : 0001974c (MIPS 74Kc)
<4>[71505.370000] Modules linked in: ath9k ath9k_common pppoe ppp_async iptable_nat ath9k_hw ath pppox ppp_generic nf_nat_ipv4 nf_conntrack_ipv6 nf_conntrack_ipv4 mac80211 ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_tcpmss xt_string xt_statistic xt_state xt_recent xt_nat xt_multiport xt_mark xt_mac xt_limit xt_length xt_id xt_hl xt_helper xt_ecn xt_dscp xt_conntrack xt_connmark xt_connlimit xt_connbytes xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_HL xt_DSCP xt_CT xt_CLASSIFY ts_kmp ts_fsm ts_bm slhc nf_nat_irc nf_nat_ftp nf_nat nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_irc nf_conntrack_ftp iptable_raw iptable_mangle iptable_filter ipt_REJECT ipt_ECN ip_tables crc_ccitt compat act_connmark nf_conntrack act_skbedit act_mirred em_u32 cls_u32 cls_tcindex cls_flow cls_route cls_fw sch_hfsc sch_ingress ledtrig_usbdev ip6t_REJECT ip6table_raw ip6table_mangle ip6table_filter ip6_tables x_tables ifb ipv6 arc4 crypto_blkcipher ohci_platform ohci_hcd ehci_platform ehci_hcd gpio_button_hotplug usbcore nls_base usb_common
<4>[71505.370000] Process hostapd (pid: 1438, threadinfo=86a80000, task=86b992c0, tls=7771f440)
<4>[71505.370000] Stack : 868bcae0 868c6b28 00000000 85e403ac 85f0143c 86e556c0 85f013ac 85ed6210
<4>[71505.370000] 00000004 85f01148 86a81790 00000004 86937918 86fe28d4 00008842 801dd3a4
<4>[71505.370000] 8782d840 868bcae0 000000a7 86a817e0 85f01000 86937900 85ed6210 00000004
<4>[71505.370000] 85f01148 86f1d8dc 85ef90c0 868c6408 00000100 85f01014 00000000 86eaf1bc
<4>[71505.370000] 00000000 86a8173c 86a8173c 00000000 868bcae0 868c6400 85e40000 8693fc00
<4>[71505.370000] ...
<4>[71505.370000] Call Trace:
<4>[71505.370000] [<86fe7770>] ath_tx_aggr_sleep+0x58/0x134 [ath9k]
<4>[71505.370000] [<86fe28d4>] ath9k_deinit_device+0x7e0/0x88c [ath9k]
<4>[71505.370000]
<4>[71505.370000]
<4>[71505.370000] Code: 26f77784 8e110024 02802021 <0dbf9c9e> 8e250000 92020049 14400005 02e02021 0c027171
<4>[71505.620000] ---[ end trace 8165c4d8bc709ece ]---

Attachments (1)

kernel crash.txt (16.5 KB) - added by jianjia 3 years ago.

Download all attachments as: .zip

Change History (8)

Changed 3 years ago by jianjia

comment:1 follow-up: Changed 3 years ago by nbd

how frequent is this crash? how do you reproduce it?

comment:2 Changed 3 years ago by bmccoy11

I have the same issue on my WNDR3700v1. I am able to reproduce it by rebooting my 2013 Nexus 7 running Android Lollipop, but I can't figure out why. It also causes my router to randomly reboot.

comment:3 in reply to: ↑ 1 Changed 3 years ago by jianjia

normally 2 or 3 days, sometimes several hours. It reboot randomly, so I don't know how to reproduce it.

comment:4 Changed 3 years ago by djdeeles@…

İ have same problem with wdr3600 LG g2 running cm12 lolipop.I can reproduce it every time. Reboot phone with Wi-Fi on after phone boot ABD connect Wi-Fi network router reboots itself.

comment:5 Changed 3 years ago by anonymous

I've also very recently (since last week) noticed spontaneous reboots upon "heavy" WiFi activity on a TP-Link WDR3600 running CC trunk. The OpenWrt/WDR3600 2.4GHz radio0 wlan0 is configured as a station to a consumer AP in a very noisy environment so the link is very unstable.

root@OpenWrt:~# logread |fgrep wlan0|fgrep netifd
Sat Dec  6 04:19:11 2014 daemon.notice netifd: Network device 'wlan0' link is up
Mon Dec  8 00:15:46 2014 daemon.notice netifd: Network device 'wlan0' link is down
Mon Dec  8 00:15:46 2014 daemon.notice netifd: Network device 'wlan0' link is up
Mon Dec  8 00:22:14 2014 daemon.notice netifd: Network device 'wlan0' link is down
Mon Dec  8 00:22:30 2014 daemon.notice netifd: Network device 'wlan0' link is up
Mon Dec  8 00:24:14 2014 daemon.notice netifd: Network device 'wlan0' link is down
Mon Dec  8 00:24:19 2014 daemon.notice netifd: Network device 'wlan0' link is up
Mon Dec  8 00:26:37 2014 daemon.notice netifd: Network device 'wlan0' link is down
Mon Dec  8 00:26:38 2014 daemon.notice netifd: Network device 'wlan0' link is up
Mon Dec  8 00:28:58 2014 daemon.notice netifd: Network device 'wlan0' link is down
Mon Dec  8 00:29:01 2014 daemon.notice netifd: Network device 'wlan0' link is up
Mon Dec  8 00:30:38 2014 daemon.notice netifd: Network device 'wlan0' link is down
Mon Dec  8 00:30:39 2014 daemon.notice netifd: Network device 'wlan0' link is up
Mon Dec  8 00:37:19 2014 daemon.notice netifd: Network device 'wlan0' link is down
Mon Dec  8 00:37:24 2014 daemon.notice netifd: Network device 'wlan0' link is up
Mon Dec  8 01:38:59 2014 daemon.notice netifd: Network device 'wlan0' link is down
Mon Dec  8 01:39:00 2014 daemon.notice netifd: Network device 'wlan0' link is up
root@OpenWrt:~#
Mon Dec  8 03:50:55 2014 daemon.notice netifd: Network device 'wlan0' link is down
Mon Dec  8 03:50:55 2014 daemon.notice netifd: Interface 'wan3' has link connectivity loss
Mon Dec  8 03:50:57 2014 kern.info kernel: [  458.430000] wlan0: authenticate with xx:xx:xx:xx:15:c4
Mon Dec  8 03:50:57 2014 kern.info kernel: [  458.450000] wlan0: send auth to xx:xx:xx:xx:15:c4 (try 1/3)
Mon Dec  8 03:50:57 2014 kern.info kernel: [  458.490000] wlan0: authenticated
Mon Dec  8 03:50:57 2014 kern.info kernel: [  458.540000] wlan0: associate with xx:xx:xx:xx:15:c4 (try 1/3)
Mon Dec  8 03:50:57 2014 kern.info kernel: [  458.560000] wlan0: RX AssocResp from xx:xx:xx:xx:15:c4 (capab=0x411 status=0 aid=1)
Mon Dec  8 03:50:57 2014 kern.info kernel: [  458.570000] wlan0: associated
Mon Dec  8 03:50:57 2014 daemon.notice netifd: Network device 'wlan0' link is up
Mon Dec  8 03:50:57 2014 daemon.notice netifd: Interface 'wan3' has link connectivity
Mon Dec  8 04:21:00 2014 daemon.notice netifd: Network device 'wlan0' link is down
Mon Dec  8 04:21:00 2014 daemon.notice netifd: Interface 'wan3' has link connectivity loss
Mon Dec  8 04:21:04 2014 kern.info kernel: [ 2266.270000] wlan0: authenticate with xx:xx:xx:xx:15:c4
Mon Dec  8 04:21:04 2014 kern.info kernel: [ 2266.290000] wlan0: send auth to xx:xx:xx:xx:15:c4 (try 1/3)
Mon Dec  8 04:21:04 2014 kern.info kernel: [ 2266.330000] wlan0: authenticated
Mon Dec  8 04:21:04 2014 kern.info kernel: [ 2266.340000] wlan0: associate with xx:xx:xx:xx:15:c4 (try 1/3)
Mon Dec  8 04:21:04 2014 kern.info kernel: [ 2266.350000] wlan0: RX AssocResp from xx:xx:xx:xx:15:c4 (capab=0x411 status=0 aid=1)
Mon Dec  8 04:21:04 2014 kern.info kernel: [ 2266.360000] wlan0: associated
Mon Dec  8 04:21:04 2014 daemon.notice netifd: Network device 'wlan0' link is up

However I can't reproduce the reboots, OpenWrt may reboot 3 times within 10 minutes or run stable for hours.

comment:6 Changed 3 years ago by bmccoy11

Is it just me, or is this fixed now as of r43587? My router is no longer crashing when I reboot my tablet and it's been stable since I've flashed it.

comment:7 Changed 3 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

yes, should be fixed now

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.