Modify

Opened 3 years ago

Last modified 2 years ago

#18450 reopened defect

lan port not working on latest trunk TL-WA901ND v2

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

Just compiled a new firmware using latest trunk ( make dirclean, make ) and cannot access apoint anymore.

In safe mode lan works. reseted configuration via cli, and lan port stops blinking midway boot and then it's off.

Flashed again via cli ( safemode ) while not keeping configurations and the lan port is still not working.

Attachments (0)

Change History (20)

comment:1 Changed 3 years ago by finas

still happening on CHAOS CALMER (Bleeding Edge, r43525)

I tested with another 901 v2, same thing.

comment:2 Changed 3 years ago by anonymous

tried again with CHAOS CALMER (Bleeding Edge, r43606) and the problem persists..

is there something I am doing wrong ? is this normal?

comment:3 follow-up: Changed 3 years ago by slimjim2234@…

Same here r43612
Lan does not start on tl-mr3020

Safemode is my only option

comment:4 Changed 3 years ago by slimjim2234@…

I managed to manually enable the wifi through safemode and mount_root, after a reboot I hopped on the wifi and did the following

here is the netifd which i think clearly states the problem
root@OpenWrt:/etc# /sbin/netifd
netifd_ubus_init(1180): connected as e3cedd5c
Failed to publish object 'network': Invalid argument
Failed to publish object 'network.device': Invalid argument
Failed to publish object 'network.wireless': Invalid argument
Failed to publish object 'network.interface': Invalid argument
proto_shell_add_handler(826): Add handler for script ./dhcp.sh: dhcp
proto_shell_add_handler(826): Add handler for script ./dhcpv6.sh: dhcpv6
proto_shell_add_handler(826): Add handler for script ./ppp.sh: ppp
proto_shell_add_handler(826): Add handler for script ./ppp.sh: pppoe

here is the dmesg:
root@OpenWrt:/etc/config# dmesg
[ 0.000000] Linux version 3.14.26 (openwrt@gb-14) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r43584) ) #1 Tue Dec 9 06:43:10 UTC 2014
[ 0.000000] MyLoader: sysp=444ba8b5, boardp=5fbcaeef, parts=ebc66edc
[ 0.000000] bootconsole [early0] enabled
[ 0.000000] CPU0 revision is: 00019374 (MIPS 24Kc)
[ 0.000000] SoC: Atheros AR9330 rev 1
[ 0.000000] Determined physical RAM map:
[ 0.000000] memory: 02000000 @ 00000000 (usable)
[ 0.000000] Initrd not found or empty - disabling initrd
[ 0.000000] Zone ranges:
[ 0.000000] Normal [mem 0x00000000-0x01ffffff]
[ 0.000000] Movable zone start for each node
[ 0.000000] Early memory node ranges
[ 0.000000] node 0: [mem 0x00000000-0x01ffffff]
[ 0.000000] On node 0 totalpages: 8192
[ 0.000000] free_area_init_node: node 0, pgdat 8035e5e0, node_mem_map 81000000
[ 0.000000] Normal zone: 64 pages used for memmap
[ 0.000000] Normal zone: 0 pages reserved
[ 0.000000] Normal zone: 8192 pages, LIFO batch:0
[ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[ 0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[ 0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[ 0.000000] pcpu-alloc: [0] 0
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 8128
[ 0.000000] Kernel command line: board=TL-MR3020 console=ttyATH0,115200 rootfstype=squashfs,jffs2 noinitrd
[ 0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[ 0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[ 0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[ 0.000000] Writing ErrCtl register=00000000
[ 0.000000] Readback ErrCtl register=00000000
[ 0.000000] Memory: 28456K/32768K available (2517K kernel code, 122K rwdata, 516K rodata, 228K init, 191K bss, 4312K reserved)
[ 0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[ 0.000000] NR_IRQS:51
[ 0.000000] Clocks: CPU:400.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:25.000MHz
[ 0.000000] Calibrating delay loop... 265.42 BogoMIPS (lpj=1327104)
[ 0.080000] pid_max: default: 32768 minimum: 301
[ 0.080000] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.090000] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.100000] NET: Registered protocol family 16
[ 0.100000] MIPS: machine is TP-LINK TL-MR3020
[ 0.380000] bio: create slab <bio-0> at 0
[ 0.390000] Switched to clocksource MIPS
[ 0.390000] NET: Registered protocol family 2
[ 0.400000] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.400000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.410000] TCP: Hash tables configured (established 1024 bind 1024)
[ 0.410000] TCP: reno registered
[ 0.420000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 0.420000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[ 0.430000] NET: Registered protocol family 1
[ 0.430000] PCI: CLS 0 bytes, default 32
[ 0.440000] futex hash table entries: 256 (order: -1, 3072 bytes)
[ 0.460000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 0.470000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[ 0.480000] msgmni has been set to 55
[ 0.480000] io scheduler noop registered
[ 0.490000] io scheduler deadline registered (default)
[ 0.490000] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[ 0.510000] ar933x-uart: ttyATH0 at MMIO 0x18020000 (irq = 11, base_baud = 1562500) is a AR933X UART
[ 0.510000] console [ttyATH0] enabled
[ 0.520000] bootconsole [early0] disabled
[ 0.530000] m25p80 spi0.0: found s25sl032p, expected m25p80
[ 0.540000] m25p80 spi0.0: s25sl032p (4096 Kbytes)
[ 0.540000] 5 tp-link partitions found on MTD device spi0.0
[ 0.550000] Creating 5 MTD partitions on "spi0.0":
[ 0.550000] 0x000000000000-0x000000020000 : "u-boot"
[ 0.560000] 0x000000020000-0x00000013b79c : "kernel"
[ 0.560000] mtd: partition "kernel" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[ 0.580000] 0x00000013b79c-0x0000003f0000 : "rootfs"
[ 0.580000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[ 0.600000] mtd: device 2 (rootfs) set to be root filesystem
[ 0.600000] 1 squashfs-split partitions found on MTD device rootfs
[ 0.610000] 0x000000320000-0x0000003f0000 : "rootfs_data"
[ 0.610000] 0x0000003f0000-0x000000400000 : "art"
[ 0.620000] 0x000000020000-0x0000003f0000 : "firmware"
[ 0.640000] libphy: ag71xx_mdio: probed
[ 1.310000] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.1:04 [uid=004dd041, driver=Generic PHY]
[ 1.310000] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode:MII
[ 1.320000] TCP: cubic registered
[ 1.320000] NET: Registered protocol family 17
[ 1.330000] Bridge firewalling registered
[ 1.330000] 8021q: 802.1Q VLAN Support v1.8
[ 1.350000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[ 1.350000] Freeing unused kernel memory: 228K (80377000 - 803b0000)
[ 4.090000] usbcore: registered new interface driver usbfs
[ 4.090000] usbcore: registered new interface driver hub
[ 4.100000] usbcore: registered new device driver usb
[ 4.110000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 4.120000] ehci-platform: EHCI generic platform driver
[ 4.120000] ehci-platform ehci-platform: EHCI Host Controller
[ 4.130000] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1
[ 4.140000] ehci-platform ehci-platform: irq 3, io mem 0x1b000000
[ 4.160000] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00
[ 4.160000] hub 1-0:1.0: USB hub found
[ 4.160000] hub 1-0:1.0: 1 port detected
[ 4.170000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[ 4.180000] ohci-platform: OHCI generic platform driver
[ 5.140000] random: mktemp urandom read with 64 bits of entropy available
[ 7.440000] eth0: link up (100Mbps/Full duplex)
[ 8.460000] jffs2: notice: (337) jffs2_build_xattr_subsystem: complete building xattr subsystem, 2 of xdatum (0 unchecked, 1 orphan) and 28 of xref (0 dead, 16 orphan) found.
[ 8.520000] eth0: link down
[ 11.150000] NET: Registered protocol family 10
[ 11.160000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[ 11.180000] Loading modules backported from Linux version master-2014-11-04-0-gf3660a2
[ 11.180000] Backport generated by backports.git backports-20141023-2-g4ff890b
[ 11.190000] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 11.210000] nf_conntrack version 0.5.0 (448 buckets, 1792 max)
[ 11.270000] xt_time: kernel timezone is -0000
[ 11.310000] cfg80211: Calling CRDA to update world regulatory domain
[ 11.310000] cfg80211: World regulatory domain updated:
[ 11.320000] cfg80211: DFS Master region: unset
[ 11.320000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 11.330000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 11.340000] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 11.350000] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[ 11.350000] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[ 11.360000] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[ 11.370000] cfg80211: (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[ 11.380000] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[ 11.390000] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[ 11.480000] PPP generic driver version 2.4.2
[ 11.480000] NET: Registered protocol family 24
[ 11.550000] ath: EEPROM regdomain: 0x0
[ 11.550000] ath: EEPROM indicates default country code should be used
[ 11.550000] ath: doing EEPROM country->regdmn map search
[ 11.550000] ath: country maps to regdmn code: 0x3a
[ 11.550000] ath: Country alpha2 being used: US
[ 11.550000] ath: Regpair used: 0x3a
[ 11.560000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[ 11.570000] cfg80211: Calling CRDA for country: US
[ 11.580000] cfg80211: Regulatory domain changed to country: US
[ 11.580000] cfg80211: DFS Master region: FCC
[ 11.580000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 11.590000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 3000 mBm), (N/A)
[ 11.600000] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 1700 mBm), (N/A)
[ 11.610000] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2300 mBm), (0 s)
[ 11.620000] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 3000 mBm), (N/A)
[ 11.630000] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[ 11.640000] ieee80211 phy0: Atheros AR9330 Rev:1 mem=0xb8100000, irq=2
[ 19.250000] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 19.250000] device eth0 entered promiscuous mode
[ 19.270000] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[ 20.940000] random: nonblocking pool is initialized
[ 21.010000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 21.030000] device wlan0 entered promiscuous mode
[ 21.050000] br-lan: port 2(wlan0) entered forwarding state
[ 21.050000] br-lan: port 2(wlan0) entered forwarding state
[ 21.060000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 21.080000] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[ 23.050000] br-lan: port 2(wlan0) entered forwarding state
[ 292.680000] br-lan: port 2(wlan0) entered disabled state
[ 292.690000] device eth0 left promiscuous mode
[ 292.690000] br-lan: port 1(eth0) entered disabled state
[ 292.710000] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 292.710000] device wlan0 left promiscuous mode
[ 292.710000] br-lan: port 2(wlan0) entered disabled state
[ 296.240000] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 296.240000] device eth0 entered promiscuous mode
[ 296.250000] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[ 297.530000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 297.600000] device wlan0 entered promiscuous mode
[ 297.640000] br-lan: port 2(wlan0) entered forwarding state
[ 297.640000] br-lan: port 2(wlan0) entered forwarding state
[ 297.650000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 297.690000] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[ 299.640000] br-lan: port 2(wlan0) entered forwarding state
[ 907.350000] br-lan: port 2(wlan0) entered disabled state
[ 907.360000] device eth0 left promiscuous mode
[ 907.360000] br-lan: port 1(eth0) entered disabled state
[ 907.380000] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 907.380000] device wlan0 left promiscuous mode
[ 907.380000] br-lan: port 2(wlan0) entered disabled state
[ 907.440000] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 907.440000] device eth0 entered promiscuous mode
[ 907.460000] device wlan0 entered promiscuous mode
[ 907.480000] br-lan: port 2(wlan0) entered forwarding state
[ 907.480000] br-lan: port 2(wlan0) entered forwarding state
[ 908.220000] device wlan0 left promiscuous mode
[ 908.220000] br-lan: port 2(wlan0) entered disabled state
[ 909.340000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 909.390000] device wlan0 entered promiscuous mode
[ 909.390000] br-lan: port 2(wlan0) entered forwarding state
[ 909.390000] br-lan: port 2(wlan0) entered forwarding state
[ 909.420000] br-lan: port 2(wlan0) entered disabled state
[ 909.440000] br-lan: port 2(wlan0) entered forwarding state
[ 909.440000] br-lan: port 2(wlan0) entered forwarding state
[ 909.450000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 911.440000] br-lan: port 2(wlan0) entered forwarding state

and ifconfig:
root@OpenWrt:/etc/config# ifconfig
br-lan Link encap:Ethernet HWaddr 64:66:B3:94:0B:F0

inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::6666:b3ff:fe94:bf0/64 Scope:Link
inet6 addr: fdc5:6fa1:ceff::1/60 Scope:Global
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3045 errors:0 dropped:0 overruns:0 frame:0
TX packets:2648 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:190763 (186.2 KiB) TX bytes:792580 (774.0 KiB)

eth0 Link encap:Ethernet HWaddr 64:66:B3:94:0B:F0

UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:5 errors:0 dropped:2 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:368 (368.0 B) TX bytes:0 (0.0 B)
Interrupt:4

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:6386 errors:0 dropped:0 overruns:0 frame:0
TX packets:6386 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:434996 (424.8 KiB) TX bytes:434996 (424.8 KiB)

wlan0 Link encap:Ethernet HWaddr 64:66:B3:94:0B:F0

inet6 addr: fe80::6666:b3ff:fe94:bf0/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3085 errors:0 dropped:0 overruns:0 frame:0
TX packets:2708 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:244226 (238.5 KiB) TX bytes:865112 (844.8 KiB)

comment:5 in reply to: ↑ 3 Changed 3 years ago by slimjim2234@…

sorry r43584

Replying to slimjim2234@…:

Same here r43612
Lan does not start on tl-mr3020

Safemode is my only option

comment:6 Changed 3 years ago by anonymous

I noticed the same problem with Nanobridge M2/5.
Normally we are using the bullet-m image for this devices -> eth0 works during boot but at the end it stops. Installing nano-m image it works until the generated wan-port (using eth1) will be deleted. Same effect has been seen by changing wan to static IP

comment:7 Changed 3 years ago by rene.reineke@…

Maybe same issue running MR3020. IF eth0 shows up but does not get any IP through DHCP. It started after pulling a recent release. It worked flawlessly with the same configuration about 5 weeks ago (when I pulled trunk last time).

comment:8 Changed 3 years ago by slimjim2234

I'll see about changing the ip to a static one tonight.
If that would fix the issue, do you guys think that udhcpd is the cause of this?

comment:9 Changed 3 years ago by anonymous

I don't think it has to do with DHCP because I flash with option to not save configuration ( so it boots default configuration ), and default configuration has static ip.

comment:10 Changed 3 years ago by finas

Guys, what's going on with this? firmware build from today also has the same problem? what is this related to?

comment:11 Changed 3 years ago by rene.reineke@…

Please see /ticket/18423.html as well.

comment:12 Changed 3 years ago by anonymous

CHAOS CALMER (Bleeding Edge, r43751)

still the same issue with the 901 v2.

any news from the dev's regarding when this will be fixed?

comment:13 Changed 3 years ago by nbd

please try r43757 - make sure you clean your kernel tree after updating.

comment:14 Changed 3 years ago by vaclav.ovsik@…

Hi,
I have similar problem with r43757 (yesterday build). I have Asus WL-500W, broadcom 47xx SoC (with serial console). I think netifd doesn't add wifi wl0 interface into lan bridge, but simple running:

/etc/init.d/network reload

does the missing configuration.

I'm trying to setup dump AP with this configuration:

root@OpenWrt:/etc/config# cat network 

config switch 'eth0'
        option name 'eth0'
        option reset '1'
#       option enable_vlan '1'
        option enable_vlan '0'

#config switch_vlan
#       option device 'eth0'
#       option vlan '1'
#       option ports '0 1 2 3 4 5'

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd52:a74c:31a0::/48'

config interface 'lan'
        option ifname 'eth0 eth1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.1.5'
        option dns '192.168.1.5'

#config interface 'wan'
#       option ifname 'eth1'
#       option proto 'dhcp'

#config interface 'wan6'
#       option ifname 'eth1'
#       option proto 'dhcpv6'

root@OpenWrt:/etc/config# cat wireless 
config wifi-device  wl0
        option type     broadcom
        option channel  1
        option txantenna 3
        option rxantenna 3
        option country  'CZ'

config wifi-iface
        option device   wl0
        option network  lan
        option mode     ap
        option ssid     ZITOJR
        option encryption psk2
        option key      ***********

The tail of boot process looks:

procd: Console is alive
procd: - watchdog -
[    4.440000] b44: Broadcom 44xx/47xx 10/100 PCI ethernet driver version 2.0
[    4.450000] libphy: b44_eth_mii: probed
[    4.610000] b53_common: found switch: BCM5325, rev 0
[    4.610000] b44 ssb0:0: attached PHY driver [Broadcom B53 (1)] (mii_bus:phy_addr=1:1e)
[    4.620000] b44 ssb0:0 eth0: Broadcom 44xx/47xx 10/100 PCI ethernet driver 00:23:54:05:14:e0
[    4.640000] libphy: b44_eth_mii: probed
[    4.640000] b44 ssb0:1: could not find PHY at 4, use fixed one
[    4.650000] b44 ssb0:1: attached PHY driver [Generic PHY] (mii_bus:phy_addr=fixed-0:00)
[    4.650000] b44 ssb0:1 eth1: Broadcom 44xx/47xx 10/100 PCI ethernet driver 00:23:54:05:14:e0
procd: - preinit -
[    5.410000] b44 ssb0:0 eth0: Link is up at 100 Mbps, half duplex
[    5.420000] b44 ssb0:0 eth0: Flow control is off for TX and off for RX
[    5.630000] random: mktemp urandom read with 53 bits of entropy available
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
[    6.610000] libphy: 1:1e - Link is Up - 100/Full
jffs2 is ready
No jffs2 marker was found
[    9.230000] jffs2: notice: (229) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (1 unchecked, 0 orp.
switching to overlay
[    9.290000] b44 ssb0:0 eth0: powering down PHY
procd: - early -
procd: - watchdog -
[    9.610000] libphy: 1:1e - Link is Down
procd: - ubus -
procd: - init -
Please press Enter to activate this console.
[   14.450000] NET: Registered protocol family 10
[   15.290000] wl: module license 'unspecified' taints kernel.
[   15.300000] Disabling lock debugging due to kernel taint
[   15.430000] SSB/BCMA glue driver successfully attached
[   15.440000] ssb: PCI: Fixing up device 0000:00:02.0
[   15.520000] wl0: Broadcom BCM4329 802.11 Wireless Controller 5.10.56.27
[   15.560000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   15.600000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   15.690000] nf_conntrack version 0.5.0 (455 buckets, 1820 max)
[   15.940000] xt_time: kernel timezone is -0000
[   15.970000] PPP generic driver version 2.4.2
[   15.980000] NET: Registered protocol family 24
[   20.190000] b44 ssb0:0 eth0: Link is up at 100 Mbps, full duplex
[   20.200000] b44 ssb0:0 eth0: Flow control is off for TX and off for RX
[   21.950000] libphy: 1:1e - Link is Up - 100/Full
[   24.890000] nas calls setitimer() with new_value NULL pointer. Misfeature support will be removed
[   25.550000] random: nonblocking pool is initialized
[   26.100000] b44 ssb0:0 eth0: powering down PHY
[   26.130000] b44 ssb0:0 eth0: Link is up at 100 Mbps, full duplex
[   26.130000] b44 ssb0:0 eth0: Flow control is off for TX and off for RX
[   26.210000] device eth0 entered promiscuous mode
[   26.210000] br-lan: port 1(eth0) entered forwarding state
[   26.220000] br-lan: port 1(eth0) entered forwarding state
[   26.340000] b44 ssb0:1 eth1: Link is up at 100 Mbps, half duplex
[   26.350000] b44 ssb0:1 eth1: Flow control is off for TX and off for RX
[   26.390000] device eth1 entered promiscuous mode
[   27.190000] br-lan: port 2(eth1) entered forwarding state
[   27.190000] br-lan: port 2(eth1) entered forwarding state
[   28.000000] libphy: fixed-0:00 - Link is Up - 100/Full
[   28.220000] br-lan: port 1(eth0) entered forwarding state
procd: - init complete -
[   29.190000] br-lan: port 2(eth1) entered forwarding state



BusyBox v1.22.1 (2014-12-20 22:12:03 CET) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 CHAOS CALMER (Bleeding Edge, r43757)
 -----------------------------------------------------
  * 1 1/2 oz Gin            Shake with a glassful
  * 1/4 oz Triple Sec       of broken ice and pour
  * 3/4 oz Lime Juice       unstrained into a goblet.
  * 1 1/2 oz Orange Juice
  * 1 tsp. Grenadine Syrup
 -----------------------------------------------------
root@OpenWrt:/# brctl show
bridge name     bridge id               STP enabled     interfaces
br-lan          7fff.0023540514e0       no              eth0
                                                        eth1
root@OpenWrt:/# ifconfig
br-lan    Link encap:Ethernet  HWaddr 00:23:54:05:14:E0  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::223:54ff:fe05:14e0/64 Scope:Link
          inet6 addr: fd52:a74c:31a0::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:55 errors:0 dropped:0 overruns:0 frame:0
          TX packets:73 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:5190 (5.0 KiB)  TX bytes:6622 (6.4 KiB)

eth0      Link encap:Ethernet  HWaddr 00:23:54:05:14:E0  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:64 errors:0 dropped:0 overruns:0 frame:0
          TX packets:78 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:6990 (6.8 KiB)  TX bytes:8593 (8.3 KiB)
          Interrupt:4 

eth1      Link encap:Ethernet  HWaddr 00:23:54:05:14:E0  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:1138 (1.1 KiB)
          Interrupt:5 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wl0       Link encap:Ethernet  HWaddr 00:23:54:05:14:E0  
          inet6 addr: fe80::223:54ff:fe05:14e0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:3497
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:224 (224.0 B)
          Interrupt:6 

root@OpenWrt:/# /etc/init.d/network reload
sh: 0xffff: bad number
[  213.400000] device wl0 entered promiscuous mode
[  213.410000] br-lan: port 3(wl0) entered forwarding state
[  213.420000] br-lan: port 3(wl0) entered forwarding state
root@OpenWrt:/# [  215.420000] br-lan: port 3(wl0) entered forwarding state

root@OpenWrt:/# brctl show
bridge name     bridge id               STP enabled     interfaces
br-lan          7fff.0023540514e0       no              eth0
                                                        eth1
                                                        wl0

Running ifdown lan and ifup lan fixes the problem online too.
Cheers
--
Zito

comment:15 Changed 3 years ago by vaclav.ovsik@…

I discovered the cause of error message

sh: 0xffff: bad number

It is apparently the code in /lib/wifi/broadcom.sh Operator -eq can't compare hexadecimal numbers directly. I tried a change to convert a hexadecimal number using arithmetic evaluation first:

--- broadcom.sh.orig	2014-12-21 19:12:40.388257139 +0100
+++ broadcom.sh	2014-12-21 19:12:40.348257323 +0100
@@ -218,7 +218,7 @@
 	}
 
 	local leddc=$(wlc ifname "$device" leddc)
-	[ "$leddc" -eq 0xffff ] || {
+	[ $(($leddc)) -eq $((0xffff)) ] || {
 		leddc=0x005a000a;
 	}
 

Reload is without the error message with this change.
--
Zito

comment:16 Changed 3 years ago by finas

nbd,

just tried with [43762] on a 901 v2 and the problem remains.
I pulled the source and compiled after doing a make dirclean.

comment:17 Changed 3 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r43776

comment:18 Changed 2 years ago by anonymous

Hello, in latest version openwrt-15.05-ar71xx-generic-tl-wa901nd-v3-squashfs-factory the problem persist!

comment:19 Changed 2 years ago by smarca@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

Hello, in latest version openwrt-15.05-ar71xx-generic-tl-wa901nd-v3-squashfs-factory the problem persist! Witch Hardware V3.

comment:20 Changed 2 years ago by anonymous

Pleasw test latest trunk version from openwrt

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.