Modify

Opened 3 years ago

Last modified 3 years ago

#18437 new defect

trunk rev 43421, dynamic dns scripts error: cannot determine interface address (IPv4)

Reported by: mgondium@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

LuCI Dynamic Dns App Message:
"Advanced Settings - IP address source [IPv4]: can not detect local IP. Please select a different Source combination"

Failed for every Interface/Network/URL.

Attachments (0)

Change History (8)

comment:1 Changed 3 years ago by chris5560

Please check, if inside directory /usr/lib/ddns
the file: dynamic_dns_lucihelper.tmp.sh
was copied/moved to: dynamic_dns_lucihelper.sh

comment:2 Changed 3 years ago by mgondium@…

The tmp.sh file was there, so I renamed it to .sh and then the process worked.

However, this required the interface to have an address,
which makes it dificult to configure a DDNS without some WAN connectivity already in place.
But maybe that's a story for another time.

Thanks!

comment:3 Changed 3 years ago by mgondium@…

Something remains borked, my DDNS is updating to the loopback address (127.0.0.1)...

comment:4 Changed 3 years ago by mgondium@…

URL mode generates several log messages like

150609 : #> /usr/bin/wget -q -O /tmp/ddns_5944.dat -Y off http://checkip.dyndns.com 2>/tmp/ddns_5944.err
150610 ERROR : Busybox Wget Error: '1'
150610 :
150610 WARN : Transfer failed - retry 3/5 in 60 seconds

If I run the command manually it completes successfully with return code 0...

comment:5 Changed 3 years ago by chris5560

For the moment please look at #18411 Comment 3

Last edited 3 years ago by chris5560 (previous) (diff)

comment:6 Changed 3 years ago by mgondium@…

All good now by removing the STDERR redirection.
Thanks chris!

Since you are aware of the issues, I think this can be closed.

comment:7 Changed 3 years ago by anonymous

Chaos Calmer trunk@43532 , TP-LINK W8970 (Lantiq -> XR200 -> TP-LINK TDW8970)

Same thing: file /usr/lib/ddns/dynamic_dns_lucihelper.tmp.sh is incorrect.
I need to change manually into /usr/lib/ddns/dynamic_dns_lucihelper.sh

comment:8 Changed 3 years ago by mgondium@…

r43534 is working ok for me without any fiddling, there's no tmp file and no busybox error. I saw the changes committed while doing the git pull.

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.