Modify

Opened 3 years ago

Closed 3 years ago

#18406 closed defect (fixed)

Switch configuration in openwrt 14.07 fails on DSL-2740B F1 AU

Reported by: yasutani Owned by: jogo
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Barrier Breaker 14.07
Keywords: Cc:

Description

I have encountered an oddity with DSL-2740B F1 AU, bcm6328 based router. I flashed the router with 14.07 via CFE. This appears to have worked correctly. However on reboot, the router would not respond on the network.

Testing and fix:

  • I booted the device into fail-safe mode and I was able to telnet into it.
  • mount_root worked
  • I checked the network config (/etc/config/network ) and it appears that the assumption is that the CPU port of the eth0 switch is port 5.
  • I then ran up swconfig and it showed that the CPU port of the switch is in fact port 8
  • I reconfigured the network config use port 8 instead of port 5 in the vlan definitions section.
  • rebooted the router
  • network started to behave

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by jogo

  • Owner changed from developers to jogo
  • Status changed from new to accepted

Hm, yepp, it's in the wrong case in /etc/uci-defaults/02_network. Let me fix that ...

comment:2 Changed 3 years ago by jogo

  • Resolution set to fixed
  • Status changed from accepted to closed

Should be fixed with r43379, r43380. Thanks for reporting!

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.