Modify

Opened 11 years ago

Closed 10 years ago

Last modified 4 years ago

#1839 closed defect (fixed)

squid broken

Reported by: MMCM Owned by: florian
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: Cc:

Description

squid cannot start it, always says

FATAL: Bungled Default Configuration line 1: http_port  none
Squid Cache (Version 2.6.STABLE12): Terminated abnormally.

regardless of the configuration file - it seems to ignore the -f parameter.
It looks like it cannot read any configuration file and the above entry in line 1 is the default value.

WL-500gx running r7213 2.4 kernel, squid compiled with the latests code checked out.
squid installed from 7.06 release has the same problem.

There already was that bug mentioned in the irc channel, but no answer there.

Attachments (0)

Change History (22)

comment:1 Changed 11 years ago by MMCM

I did a complete recompile with r7526, still the same problem...

comment:2 Changed 11 years ago by MMCM

An older version of squid which runs fine on a wgt634u with kamikaze r5895, logs the following error to cache.log:

2007/06/10 03:16:28| /var/cache/squid is not a directory
FATAL:  Failed to verify one of the swap directories, Check cache.log
        for details.  Run 'squid -z' to create swap directories
        if needed, or if running Squid for the first time.
Squid Cache (Version 2.5.STABLE14): Terminated abnormally.

/var/cache/squid was created with squid -z and has permissions set correctly...

Maybe a problem with any shared library, like libuClibc?

comment:3 Changed 11 years ago by MMCM

I rebuild kamikaze r7603 and squid from scratch for a wgt634u, no change:

# /usr/sbin/squid
FATAL: Bungled Default Configuration line 1: http_port  none
Squid Cache (Version 2.6.STABLE12): Terminated abnormally.

Is there nobody else using squid?

comment:4 Changed 11 years ago by MMCM

I tried the squid 2.6.STABLE9-1 package from the optware feed (http://ipkg.nslu2-linux.org/feeds/optware/ddwrt/cross/stable/), and it works fine, except the missing features for transparent proxying :-/

comment:5 Changed 11 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to assigned

I do care about running squid, just did not find the time to fix this.

comment:6 Changed 11 years ago by Gabriel

Same error on a wrtg54gl with kamikaze and backports:

# /usr/sbin/squid
FATAL: Bungled Default Configuration line 1: http_port none
Squid Cache (Version 2.6.STABLE12): Terminated abnormally.

comment:7 Changed 11 years ago by florian

  • Resolution set to fixed
  • Status changed from assigned to closed

I have upgraded squid in [7970], can you have a try ? Looks like its internal parser fails to read the config file.

comment:8 Changed 11 years ago by florian

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:9 Changed 11 years ago by Gabriel

root@OpenWrt:~# wget http://downloads.openwrt.org/backports/rc6/squid_2.5.STABLE13-1_mipsel.ipk
Connecting to downloads.openwrt.org [195.56.146.238:80]
squid_2.5.STABLE13-1 100% || 385 KB 00:00:00 ETA
root@OpenWrt:~# ipkg install squid_2.5.STABLE13-1_mipsel.ipk
Installing squid (2.5.STABLE13-1) to root...
Configuring squid
Done.
root@OpenWrt:~# squid -z
Aborted

comment:10 Changed 11 years ago by skeptix@…

Same problem with squid_2.5.STABLE14-1 (package from x-wrt.org). The parser does not read the config file. This is not a problem of the file rights, the permissions of /etc/squid/squid.conf were set to 777 for testing purposes.

comment:11 Changed 11 years ago by pavlov

there was debate as to if this is the correct solution, but try this to solve your problem:

https://dev.openwrt.org/browser/packages/net/squid/patches/006-makefile.in.patch?rev=7150

comment:12 Changed 11 years ago by florian

  • Resolution set to fixed
  • Status changed from reopened to closed

Should be fixed with [8301]

comment:13 follow-up: Changed 10 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

Still the same problem:

root@OpenWrt:~# squid -z
2000/01/01 00:06:40| Creating Swap Directories
FATAL: Failed to make swap directory /var/cache/06/E4: (28) No space left on device
Squid Cache (Version 2.5.STABLE14): Terminated abnormally.
CPU Usage: 0.620 seconds = 0.200 user + 0.420 sys
Maximum Resident Size: 0 KB
Page faults with physical i/o: 8

Gabriel

comment:14 in reply to: ↑ 13 Changed 10 years ago by Bartman007

Replying to anonymous:

Still the same problem:

root@OpenWrt:~# squid -z
2000/01/01 00:06:40| Creating Swap Directories
FATAL: Failed to make swap directory /var/cache/06/E4: (28) No space left on device
Squid Cache (Version 2.5.STABLE14): Terminated abnormally.

That error message indicates that you are running out of space for the cache; this is not a bug with OpenWrt. You'll need to move the squid cache to another storage device.

comment:15 Changed 10 years ago by florian

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:16 Changed 10 years ago by Gabriel

  • Resolution fixed deleted
  • Status changed from closed to reopened

I know but the problem is that I have plenty of space left :) this is a bug with squid.

Gabriel

comment:17 Changed 10 years ago by anonymous

I know but the problem is that I have plenty of space left :) this is a bug with squid.

Do you also have enough inodes left? Lacking inodes will result in "no space left" even if "df" shows 100GB free.

You could try deleting some other files (the number counts, not the size). To get more inodes, you'll have to pass an option to mkfs.

comment:18 Changed 10 years ago by anonymous

Squid 2.6 not compatible with linux 2.4 kernel.
There is a patch fix that, but sorry, i lost the URL.

Below is a note from debian bugs list:

Squid Cache (Version 2.6.STABLE14): Terminated abnormally.
CPU Usage: 0.130 seconds = 0.050 user + 0.080 sys
Maximum Resident Size: 0 KB
Page faults with physical i/o: 315
FATAL: comm_select_init: epoll_create(): (89) Function not implemented

http://www.mail-archive.com/debian-bugs-rc(at)lists.debian.org/msg65302.html

severity 380652 important
retitle 380652 squid 2.6 needs epoll() support which is not in kernel 2.4.x retitle 377697 squid 2.6 compiled with epoll() support does not start with kernel <= 2.6.x

merge 380652 377697
thanks

Hi Ambrose,

squid 2.6.STABLE is compiled with epoll() support turned on by default. The epoll() functions are supported only in kernels 2.6.x.

Since etch will ship with 2.6 as default and 2.4 will not be supported anymore, squid will carry a notice in README.Debian stating that kernels previous than 2.6.x are not supported anymore.

comment:19 Changed 10 years ago by anonymous

Someone ever tried to ./configure squid with "--enable-epoll" ?

comment:20 Changed 10 years ago by florian

  • Resolution set to fixed
  • Status changed from reopened to closed

Marked 2.6 kernels only with [9817]. I assume issues are fixed with 2.6 kernels.

comment:21 Changed 10 years ago by slackers_only@…

FATAL: ERROR: Unknown policy lru

Squid Cache (Version 2.6.STABLE14): Terminated abnormally.
CPU Usage: 0.004 seconds = 0.004 user + 0.000 sys
Maximum Resident Size: 0 KB
Page faults with physical i/o: 0
Aborted (core dumped)

I don't understand, its means that?
thx b4 n help me...

comment:22 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.