Modify

Opened 11 years ago

Closed 11 years ago

Last modified 6 years ago

#1838 closed defect (worksforme)

Madwifi AP Mode memory leak

Reported by: mancho <giampaolo.mancini@…> Owned by: nbd
Priority: highest Milestone:
Component: base system Version:
Keywords: Cc:

Description

There is a memory leak in madwifi when setting a device in AP mode on the radio channel on which are already present both APs and Ad-Hoc networks.
The memory usage grows at rate depending from the traffic rate on such adjacent APs and Ad-Hoc networks.

I did a try both with mini-PCI Wistron CM9 and Senao NL5354MP+ARIES2.

I'm running OpenWRT trunk.

Attachments (0)

Change History (7)

comment:1 Changed 11 years ago by mancho <giampaolo.mancini@…>

The memory leak does not present if you put the 802.11g Protection Mode off.

iwpriv ap0 protmode 0

comment:2 Changed 11 years ago by nbd

  • Owner changed from developers to nbd
  • Status changed from new to assigned

comment:3 Changed 11 years ago by nbd

Which trunk rev are you running?

comment:4 Changed 11 years ago by mancho <giampaolo.mancini@…>

The running image was built with r7515.

I'll check ASAP with a more recent one.

comment:5 Changed 11 years ago by nbd

Would you have some time to join #openwrt on irc.freenode.net and contact me for some more testing? I'd like to get this issue resolved asap.

comment:6 Changed 11 years ago by nbd

  • Resolution set to worksforme
  • Status changed from assigned to closed

please try the lastest version. should be fixed now

comment:7 Changed 11 years ago by nbd

update: finally managed to reliably reproduce it and fixed it in [7850]

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.