Modify

Opened 11 years ago

Closed 11 years ago

Last modified 4 years ago

#1836 closed defect (fixed)

openswan-2.4.8 breaks kamikaze linux-2.4-brcm build

Reported by: anonymous Owned by: florian
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: Cc:

Description

During sompilation recent svn tree (7513) received following error:

/home/andy/wl500/kamikaze/trunk/build_mipsel/linux-2.4-brcm/openswan-2.4.8/linux/net/ipsec/ipsec_proc.c:619: error: syntax error before "int"

Following change resolves problem (tested 2.4 only):
-

-- build_mipsel/linux-2.4-brcm/openswan-2.4.8/linux/net/ipsec/ipsec_proc.c~   2006-11-15 23:21:39.000000000 +0100
+++ build_mipsel/linux-2.4-brcm/openswan-2.4.8/linux/net/ipsec/ipsec_proc.c    2007-06-07 01:56:04.000000000 +0200
@@ -27,6 +27,7 @@
 #include <linux/version.h>
 #define __NO_VERSION__
 #include <linux/module.h>
+#include <linux/moduleparam.h>
 #include <linux/kernel.h> /* printk() */

 #include "openswan/ipsec_kversion.h"

~Andy

Attachments (0)

Change History (3)

comment:1 Changed 11 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to assigned

comment:2 Changed 11 years ago by florian

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in [7616], thanks !

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.