Modify

Opened 3 years ago

Closed 3 years ago

#18325 closed defect (fixed)

kernel panic when using ipv6-nat (sunxi)

Reported by: 42@… Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

Scenario:

  • PC is connected to OpenWRT box
  • OpenWRT announces router advertisements to PC
  • PC accesses resources of the IPv6 network behind the OpenWRT box (e.g. ping6 anyipv6host)
  • kernel panic happens as soon as some data passes the box from PC to IPv6 network, using ipv6-nat

(No, I can't "just" route to that IPv6 network, since it's a special IPv6 - it's the encrypted cjdns-IPv6 and therefore, ipv6-nat makes sense here to translate between encrypted ipv6 and non-encrypted ipv6 for PCs having no cjdns running behind the OpenWRT box)

This only happens on the Banana Pi (sunxi), it works on x86_64.

Attachments (2)

kernel-panic-nat6.txt (12.1 KB) - added by 42@… 3 years ago.
error-proto-ksyms.txt (4.9 KB) - added by avalentin 3 years ago.
Error on ar71xx with kernel 3.14

Download all attachments as: .zip

Change History (7)

Changed 3 years ago by 42@…

comment:1 Changed 3 years ago by avalentin

Hi!

I can tell you that this error also happens on ar71xx plattform. Please see attached log.
This should fix it:
http://patchwork.ozlabs.org/patch/349076/

I will report ;-)

comment:2 Changed 3 years ago by avalentin

Sorry, duplicate because of POST error.

Last edited 3 years ago by avalentin (previous) (diff)

Changed 3 years ago by avalentin

Error on ar71xx with kernel 3.14

comment:3 Changed 3 years ago by avalentin

Hi Reporter,

could you check if the upper patch solves your problem? I now have another oops, but I'm not sure if it has something to do with this one.

Please take a look here:
https://www.mail-archive.com/openwrt-devel@lists.openwrt.org/msg27701.html

comment:4 Changed 3 years ago by nbd

please test r43567

comment:5 Changed 3 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fix was confirmed in #18462

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.