Modify

Opened 3 years ago

Closed 3 years ago

#18317 closed defect (no_response)

[Busybox] ash problem with a directory named bind or/and special PS1

Reported by: apcrt Owned by: developers
Priority: low Milestone: Barrier Breaker 14.07
Component: packages Version: Barrier Breaker 14.07
Keywords: Cc:

Description

Problem :

After, i go to /etc/bind directory (cd /etc/bind).
I type ls command, and after when i hit enter key ash shell bug and don't return to the next line.
If you change directory, the problem don't continue. It happens only when you are in the directory.

The problem is anytime reproductible and are not "bind-server" package dependent.
You can reproduce it as this :
# mkdir /tmp/bind (or mkdir /etc/bind, dont)
# cd /tmp/bind (or cd /etc/bind)
# ls
Type enter key and see.

Context :

-My openwrt is installed on Attitude Adjutement from 14.07 (rsynced on 18/10/2014).
-I have tune my prompt throught /etc/profile with this :
export PS1="\e[3;37m[\t]\e[m [\e[0;34m\u\e[m@\e[0;31m\H\e[m: \e[0;34m\w\e[m]$ "

I think this problem is on ash / busybox binary with tuned prompt and/or a directory named bind.

Good luck and ask me if you want more elements.

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by anonymous

I can't reproduce this. What device are you using?

comment:2 Changed 3 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.