Modify

Opened 3 years ago

Closed 3 years ago

#18306 closed defect (duplicate)

kissdx does not build with eglibc x86 architecture due to --strip-all

Reported by: whotopia@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Barrier Breaker 14.07
Keywords: kissdx Cc:

Description

cmake gets passes the argument --strip-all, which it doesn't understand

The following patch to the package Makefile seems to do the trick:

--- Makefile- 2014-11-06 20:29:42.699127379 +0100
+++ Makefile 2014-11-06 20:30:21.711127021 +0100
@@ -42,7 +42,7 @@ define Build/Compile

$(MAKE) -C $(PKG_BUILD_DIR) \

CFLAGS="$(TARGET_CFLAGS) -DLinux -DUSE_INTERNAL_SENDFILE -std=gnu99 -Wall -Wstrict-prototypes -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -DFILE_OFFSET_BITS=64 -D_GNU_SOURCE -I$(ICONV_PREFIX)/include -I$(STAGING_DIR)/usr/include/dvdread $(TARGET_CPPFLAGS) $(TARGET_LDFLAGS) -L$(ICONV_PREFIX)/lib" \
LDFLAGS="-L$(ICONV_PREFIX)/lib $(TARGET_LDFLAGS)" \

  • STRIP=$(STRIP) \

+ STRIP="$(STRIP)" \

IconvExternal=defined \
CC="$(TARGET_CROSS)gcc" all

endef

Note I am unsure what this patch will do for other architectures or ulibc

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by florian

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18305

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.