Modify

Opened 3 years ago

Last modified 3 years ago

#18289 new defect

Yaffs2: disk space

Reported by: cameixieira Owned by: developers
Priority: highest Milestone: Barrier Breaker 14.07
Component: base system Version: Barrier Breaker 14.07
Keywords: yaffs2, routerboard, rb411, kernel Cc:

Description

Hi all,

I'm using a routerboard 411 with openwrt and after a while the disk space is consumed hitting 100% with less then 50% actually occupied. It is basically the same bug caught by Leonardo (/ticket/16651.html).

I did the same tests that Leonardo explained in his post and the result is similar. I run the exactly the same command as he did:

i=1; while [ $i -lt 105 ]; do echo "run # $i"; rm -f /teste; dd if=/dev/urandom of=/teste bs=1M count=6; rm -f /teste; df | head -2; i=$(($i + 1)); done

The difference is that in his case, after the reboot, the disk space is going from 10% to 70%, so in my case the difference is not that much , but the disk space is still getting used (around 200K each time the board reboot).

I first tried with the r35323, but then I tried with the r42625 and the problem still there.

After a while the disk will just run out of space and the only way to recover it remotely is to run an initramfs using the kexec tool, copying the filesystem to an USB storage, erasing the rootfs partition and copying the filesystem to the mtd partition again. As you can imagine it is a very risky operation, because many things can go wrong during this process.

Can you tell me what I can do to fix it or even if it is a known problem?

Thanks.

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by jow

This looks like a dupe of #16651

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.